Flexera One – NAM – Intermittent Service Degradation

Incident Report for Flexera System Status Dashboard

Resolved

Our technical teams have completed validation of the affected areas and confirmed that services have been fully restored.

The platform is now operating normally, and we are continuing to monitor to ensure sustained stability. This issue is considered resolved, and further details will be shared in a post-mortem report.
Posted May 09, 2026 - 02:47 PDT

Monitoring

Our technical teams are actively investigating and validating the affected areas while continuing to monitor overall service behavior. Initial findings suggest the issue may have been influenced by a service provider disruption, which has now been resolved.

We are continuing to assess any residual impact and closely monitoring the platform to ensure stability. Further updates will be provided as more information becomes available.
Posted May 09, 2026 - 01:29 PDT

Investigating

Incident Description: We are investigating a service degradation affecting Flexera One customers in the NAM region. Customers may experience intermittent errors, delayed page loading, or pages remaining in a loading state when accessing certain areas of the application, including Cloud Cost Optimization functionality and Administration > Shared Settings. Some Cloud Cost Optimization customers may also experience delays in cost data processing.

Priority: P2

Restoration Activity: Our technical teams are actively investigating and validating the affected areas. We are also monitoring upstream service provider disruptions that may be contributing to the issue. We will continue to monitor service behavior and work toward restoration.

We will provide another update as soon as additional information is available.
Posted May 08, 2026 - 15:44 PDT
This incident affected: Snow Atlas (Snow Atlas - America, Snow Atlas API - America) and Flexera One - Cloud Management - North America (Cloud Cost Optimization - US).