Flexera One – IT Visibility - EU – Reports Displaying as Blank

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One – IT Visibility - EU – Reports Displaying as Blank

Timeframe: 14 January 2026, 12:00 AM PST to 14 January 2026, 05:30 AM PST

Incident Summary

On Wednesday, 14 January 2026, at 12:00 AM PST, monitoring alerts and customer reports identified an issue impacting IT Visibility (ITV) Power BI reports in the EU region, where reports were loading without any data. While customers were able to access the Power BI reporting interface, both current and historical data appeared blank, resulting in a temporary loss of reporting visibility.

Upon identification, technical teams promptly initiated an investigation and determined that the issue occurred during a scheduled system update. During this activity, the reporting platform experienced temporary resource constraints, which prevented report data refresh processes from completing successfully. As a result, reports were displayed without data until the refresh operations could resume and complete.

To mitigate customer impact while the investigation was ongoing, manual dataset refreshes were initiated for urgent cases, enabling earlier restoration of reporting visibility for those customers. Once system resource utilization stabilized following the deployment and all remaining refresh processes completed successfully, full reporting functionality was restored for all EU customers by 05:30 PST.

Root Cause

The incident occurred during an ongoing maintenance that did not require scheduled downtime. During this maintenance activity, the reporting system experienced temporary capacity limitations, which delayed the refresh of report data. Until the refresh processes completed successfully, reports were displayed without data.

Remediation Actions

  • Manual dataset refreshes were performed for urgent customer cases to reduce impact.
  • System resources stabilized following the maintenance.
  • Automated dataset refresh processes completed successfully.
  • ITV report visibility was fully restored for all EU customers.

Future Preventative Measures

Short-Term Actions:

  • System capacity adjustments during deployments: Our teams will implement controlled, temporary increases in system capacity during deployment activities to better accommodate short-term load increases. This approach is intended to ensure that report data refresh processes continue to run reliably while updates are being applied.
  • Improvements to refresh processing behavior: The report data refresh process is being refined to reduce system strain during updates. This includes optimizing how refresh activities are triggered and executed so that data updates are processed more efficiently and do not overwhelm system resources during deployment windows.

Long-Term Improvement:

  • Our teams are working on an enhancement to improve how report data is refreshed during deployments, making the process more dynamic and efficient.
Posted Jan 28, 2026 - 04:37 PST

Resolved

The update has been successfully rolled out to all affected organizations, and report visibility has been confirmed as restored. The issue is now fully resolved.
Posted Jan 14, 2026 - 06:04 PST

Identified

Incident Description: We have identified a service disruption impacting Flexera One IT Visibility (ITV) in the EU region. Customers may experience issues accessing certain reports, with report outputs appearing as blank.

Priority: P2

Restoration Activity: Technical teams are actively investigating the issue and working to restore full reporting functionality. A probable root cause has been identified, and efforts are underway to implement and release a fix. The situation is being closely monitored, and additional updates will be shared as more information becomes available.
Posted Jan 14, 2026 - 03:42 PST
This incident affected: Flexera One - IT Visibility - Europe (IT Visibility EU).