Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 09, 2026 - 05:30 PDT
Scheduled
Maintenance will be performed on Snow Atlas production cluster across Australia-hosted environments as part of the migration activity. Impact: Users may experience temporary unavailability for impacted applications during the migration and application restart activities. Reason: To support migration activities, infrastructure modernization, and platform resiliency improvements. Dates/Times: IST: June 9th, 6:00 PM to 8:00 PM UTC: June 9th, 12:30 PM to 2:30 PM UK Time (BST): June 9th, 1:30 PM to 3:30 PM Sweden Time (CEST): June 9th, 2:30 PM to 4:30 PM AEST: June 9th, 10:00 PM to June 10th, 12:00 AM PDT: June 9, 2026, 5:30 AM – 7:30 AM PDT
Posted Jun 06, 2026 - 01:11 PDT
This scheduled maintenance affected: Snow Atlas (Snow Atlas - Australia, Snow Atlas API - Australia, Snow Atlas).