Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 03, 2025 - 00:00 PDT
Scheduled
Flexera will be performing updates to the Power BI data models and reports on the US instances of the Technology Intelligence (TI) platform. During this maintenance window, all IT Visibility and Cloud License Management (CLM) customers may be impacted. Power BI reports may either not display the most up-to-date data or may fail to load entirely during this period.
PDT: July 03 00:00 am - 02:00 am CDT: July 03 02:00 am - 04:00 am CEST: July 03 09:00 am - 11:00 am AEST: July 03 05:00 pm - 07:00 pm UTC: July 03 07:00 am - 09:00 am EDT: July 03 03:00 am - 05:00 am IST: July 03 12:30pm - 02:30pm
Posted Jun 26, 2025 - 09:28 PDT
This scheduled maintenance affected: Flexera One - IT Visibility - North America (IT Visibility US) and Flexera One - Cloud License Management - North America (Cloud License Management - US).