The issue affecting access to Flexera One services in the North America region has been fully resolved. The platform has remained stable following recovery, and customers should now be able to access services without further interruption.
Our investigation identified that a temporary disruption within one of the underlying service components caused requests to fail and led to the error messages some customers experienced. The affected component recovered after additional capacity became available and service responsiveness returned to normal.
We are reviewing the factors that contributed to this disruption and will be implementing improvements to help reduce the likelihood of a similar event in the future.
Posted Dec 09, 2025 - 15:02 PST
Monitoring
Recent activity within the environment has resulted in improved responsiveness, and some users are now able to log in successfully.
We are closely monitoring these improvements and will provide further updates as validation continues.
Posted Dec 09, 2025 - 14:18 PST
Investigating
Issue Description: We are currently investigating a service degradation affecting the Flexera One platform in the North America region. Customers may experience issues accessing services at this time.
Priority: P1
Restoration Activity: Our technical teams have been engaged and are working to identify the underlying cause and determine the scope of impact. Further updates will be shared as the investigation progresses.
Posted Dec 09, 2025 - 14:10 PST
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Beacon Communication, IT Asset Management - US Inventory Upload, IT Asset Management - US Login Page, IT Asset Management - US Batch Processing System, IT Asset Management - US Business Reporting, IT Asset Management - US SaaS Manager), Flexera One - IT Visibility - North America (IT Visibility US), Flexera One – APIs – North America (api.flexera.com), Flexera One - Cloud License Management - North America (Cloud License Management - US), Flexera One - Cloud Commitment Management (Cloud Commitment Management - US), and Flexera One - Cloud Management - North America (Cloud Cost Optimization - US, Cloudscape).