Snow Atlas - Australia - Few SAM core pages are not loading

Incident Report for Flexera System Status Dashboard

Resolved

Our teams identified an issue affecting the database server and performed a restart, which successfully restored service. We will continue to investigate the underlying root cause to determine what led to the issue and identify any necessary preventative measures. Additional details and findings will be shared in a post-mortem report.
Posted Jun 11, 2026 - 23:24 PDT

Investigating

Incident Description: We are investigating an issue affecting a small subset of customers in the Australia production environment using Snow Atlas. Affected users may be unable to access certain Snow Atlas pages, including the Home page and SAM Core Overview page.

Priority: P2

Restoration Activity: Technical teams have engaged and are actively investigating the issue. Current analysis confirms the impact is limited to a small subset of customers in the Australia region. We are closely monitoring the environment and will provide further updates as additional information becomes available.
Posted Jun 11, 2026 - 18:38 PDT
This incident affected: Snow Atlas (Snow Atlas - Australia, Snow Atlas API - Australia).