Flexera One - IT Asset Management-NAM- Service Disruption

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One - IT Asset Management-NAM- Service Disruption

Timeframe: July 29, 2025, 9:01 PM PDT to July 30, 2025, 12:48 AM PDT

Incident Summary

On Tuesday,  July 29, 2025, at 9:01 PM PDT, we experienced a service disruption impacting access to Flexera One – IT Asset Management (ITAM) in the North America Production environment. The disruption occurred during an upgrade to version 2025R1.1, which required an extended maintenance window. During the incident, customers were unable to access the ITAM section of the platform, and all ITAM features were unavailable via the web UI.

The issue began when a long-running import task needed to be manually terminated before the upgrade could proceed. This delay was followed by additional deployment issues, possibly linked to the initial holdup. While attempting to bring services back online, the initial provisioning attempt failed due to unknown causes. Ultimately, our teams terminated the affected fleet and redeployed the infrastructure, which successfully restored service availability at 12:48 AM PDT on July 30, 2025.

Root Cause

 

The service disruption was caused by a combination of factors:

  • A long-running import task delayed the upgrade process by requiring manual termination.
  • Subsequent deployment issues arose, potentially as a result of the initial delay.
  • The initial provisioning attempt during service restoration failed due to unknown issues, requiring a full redeployment of the infrastructure.

Remediation Actions 

 

·        Manually terminated the long-running import task to allow the upgrade to proceed.

·        Initiated a manual refresh of instances to restore partial service availability.

·        Terminated the affected fleet and redeployed the infrastructure to restore full service availability.

·        Verified that all web servers were back online and passing health checks before concluding the incident.

Future Preventative Measures 

 

·        Root Cause Investigation – Conduct a deeper analysis of the provisioning failure to identify and address the underlying cause.

·        Deployment Resilience – Enhance deployment processes to handle provisioning failures gracefully without full redeployment. Although the process exists, it encountered an issue in this instance.

·        Improved Maintenance Window Planning – Incorporate contingency buffers into maintenance schedules to account for unexpected delays without impacting service availability. We will also consider scheduling longer windows for batch tasks.

Posted Aug 18, 2025 - 05:35 PDT

Resolved

All upgrade activities have been successfully completed, and all services have been fully restored.
Posted Jul 30, 2025 - 00:55 PDT

Update

Our teams are actively working to complete the upgrade and restore all services. While progress has been made and some services are now back online, a few are taking longer than expected, resulting in delays. We’ve implemented additional measures to accelerate recovery efforts. Further updates will be shared as they become available.
Posted Jul 30, 2025 - 00:16 PDT

Identified

Incident Description: Our teams have identified issues during the upgrade of Flexera One – IT Asset Management to version 2025R1.1 in the North America Production environment. These issues have necessitated an extension of the planned maintenance window. As a result, IT Asset Management is currently inaccessible to customers.

Priority: P1

Restoration Activity: Engineering teams are actively working to complete the upgrade process. The final set of database uploads is currently in progress. Once completed, services will be restored, and IT Asset Management will be brought back online.

We will continue to provide updates as progress is made.
Posted Jul 29, 2025 - 22:33 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Beacon Communication, IT Asset Management - US Inventory Upload, IT Asset Management - US Login Page, IT Asset Management - US Batch Processing System, IT Asset Management - US Business Reporting).