Technical teams completed the required updates to restore communication through the affected service path in the North America environment. Upload and download requests are now completing successfully, and functionality has been validated. We will continue monitoring to ensure the service remains operational. This incident has been resolved.
Posted May 07, 2026 - 12:38 PDT
Identified
Our technical teams have identified the issue as a routing/configuration problem affecting Beacon communication following recent maintenance activity in the North America environment. This is preventing Beacon from successfully completing upload and download requests. Teams are working on the required configuration update to restore Beacon connectivity. We will provide another update as restoration work continues.
Posted May 07, 2026 - 11:07 PDT
Investigating
Incident Description: We are currently investigating an issue affecting Beacon connectivity in the Flexera One IT Asset Management application in the North America region. Customers using Beacon may experience connectivity errors when attempting to upload inventory data or download Beacon-related updates.
Priority: P2
Restoration Activity: Our technical teams are actively investigating the issue and working to restore normal Beacon upload and download functionality. We will provide updates as more information becomes available.
Posted May 07, 2026 - 09:49 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Beacon Communication).