The fix has been successfully implemented in the APAC region. After monitoring the platform for stability, we can confirm that the issue has been resolved.
Posted Jun 23, 2025 - 05:35 PDT
Update
Our teams have implemented a fix in the EU region, and Power BI reports have been successfully restored. Efforts are now underway to restore Power BI reports in the APAC region.
Posted Jun 23, 2025 - 03:24 PDT
Identified
The root cause has been identified, and we are in the process of validating a fix.
Posted Jun 23, 2025 - 02:08 PDT
Update
We are continuing to investigate this issue.
Posted Jun 23, 2025 - 00:34 PDT
Update
We are continuing to investigate this issue.
Posted Jun 23, 2025 - 00:20 PDT
Update
During the investigation, our teams identified that the impact also extends to the EU region and is affecting CLM as well. We continue to investigate this issue and will provide further updates once available.
Posted Jun 23, 2025 - 00:12 PDT
Investigating
Incident Description: Our teams have identified a service disruption affecting the IT Visibility Platform, impacting customers in the APAC region. As a result, affected users may encounter an error when attempting to load the out-of-the-box version of Power BI reports. The impact also extends to Cloud license management. Please note that custom reports continue to load as expected.
Priority: P2
Restoration activity: Our technical teams are actively investigating this issue. They are working to restore the services and identify the underlying root cause .
Posted Jun 22, 2025 - 22:37 PDT
This incident affected: Flexera One - IT Visibility - Europe (IT Visibility EU), Flexera One - IT Visibility - APAC (IT Visibility - APAC), Flexera One - Cloud License Management - Europe (Cloud License Management - EU), and Flexera One - Cloud License Management - APAC (Cloud License Management - APAC).