Flexera One – SaaS Manager - Saas Inventory Import failures

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One – SaaS Manager – All Regions – Inventory Import Failures

Timeframe: March 2, 2026, 1:09 AM PST – March 3, 2026, 9:05 AM PST

Incident Summary

On March 2, 2026, at 1:09 AM PST, reports were received indicating that Flexera SaaS Manager inventory imports were failing for multiple customers. During this period, affected imports were unable to complete successfully and returned an error indicating that the system was unable to obtain an access token required for processing the import workflow.

The issue affected customers across multiple regions and resulted in scheduled SaaS Manager imports failing to execute as expected. Other Flexera platform functionality remained available during this time.

Technical teams engaged to investigate the issue and identified that the failures were related to a service responsible for issuing authentication tokens used during the SaaS Manager import process. Recovery activities were initiated to restore normal service behavior and ensure the affected service was functioning correctly across all environments.

Following the corrective actions, successful SaaS Manager imports were observed across multiple regions, confirming that the issue had been resolved. Additional monitoring and validation were performed to ensure that the service continued operating as expected.

By March 3, 2026, at 9:05 AM PST, successful imports had been confirmed across regions and the incident was formally closed.

Root Cause

The disruption occurred due to a configuration issue affecting the service responsible for issuing authentication tokens used during the SaaS Manager import process. As a result, the service was unable to provide the required access tokens needed for import processing.

Because SaaS Manager imports depend on this authentication service, import jobs were unable to obtain the required access token and therefore failed after retry attempts were exhausted.

Remediation Actions

  1. Service Configuration Correction: The configuration affecting the authentication service was corrected to restore its ability to issue access tokens required by SaaS Manager imports.
  2. Service Update Across Environments: The service responsible for authentication was updated across all regions and environments to ensure consistent operation.
  3. Infrastructure Validation: After the update, the authentication service was verified to be running correctly across environments.
  4. Functional Verification: Successful SaaS Manager imports were confirmed across multiple regions following the fix, verifying that the import process was functioning normally.
  5. Post-Restoration Monitoring: Additional monitoring and validation activities were performed to ensure imports continued to succeed after the service update.

Future Preventative Measures
This incident highlighted the importance of monitoring and resilience for services responsible for authentication and import processing within the platform.
Based on this experience, the following measures are being applied:

  1. Monitoring and Alerting Improvements: Additional alerting and monitoring capabilities are being introduced to help detect similar service disruptions earlier and enable faster remediation.
  2. Configuration Safeguards: The service configuration has been updated to prevent the behavior that caused the authentication service disruption observed during this incident.
Posted Mar 16, 2026 - 12:26 PDT

Resolved

The issue affecting Flexera SaaS Manager and related inventory import processes has been resolved.

Our team identified and corrected a service configuration issue that impacted authentication requests required for certain import and reconciliation jobs. The affected service has been restored across all regions.

Validation confirms that inventory imports are executing successfully, and no further impact has been observed.

We will continue to monitor the environment closely as a precaution. A detailed review is underway to ensure additional safeguards are in place to prevent recurrence.
Posted Mar 03, 2026 - 09:29 PST

Monitoring

Our teams team dentified that an associated service had not been updated. As a result, traffic was not being routed to the cluster.
The required service updates have now been completed across all regions and environments, and traffic routing has been restored accordingly. We will continue to monitor the services to ensure stability.
Posted Mar 03, 2026 - 03:40 PST

Update

We are continuing to investigate this issue.
Posted Mar 03, 2026 - 02:30 PST

Investigating

After an extended period of monitoring, our teams have observed that FSM imports continue to fail . The issue remains under active investigation, with technical teams fully engaged to identify and address the underlying cause.

We will share further updates as more information becomes available.
Posted Mar 03, 2026 - 02:30 PST

Monitoring

Incident Description: Our teams have identified and are actively investigating an issue impacting SaaS inventory imports across all regions. Affected customers may experience import failures and timeouts while processing uploads.

Priority: P2

Restoration Activity: Our teams identified the root cause as an issue with the authentication service and implemented a configuration update to resolve it. The service has now returned to normal operation, and our teams are closely monitoring the environment to ensure continued stability.
Posted Mar 02, 2026 - 12:46 PST
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US SaaS Manager), Flexera One - IT Asset Management - APAC (IT Asset Management - APAC SaaS Manager), and Flexera One - IT Asset Management - Europe (IT Asset Management - EU SaaS Manager).