Flexera One - IT Asset Management - EU - Inventory Data Upload Delayed

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One - IT Asset Management - EU - Inventory Data Upload Delayed

Timeframe: November 24th, 4:41 AM to November 24th, 6:26 AM PST

Incident Summary

On Friday, November 24th, at 4:41 AM PST, we received reports of customers experiencing difficulties accessing inventory data on the IT Asset Management platform. This may have caused delays for some customers, particularly in the EU region, while other regions remained unaffected.

Our technical teams responded promptly to resolve the issue. After a thorough investigation, it was identified that the problem may have arisen from one of the tenant IDs initiating an operation that failed to finish, resulting in a backlog of all other inventory data.

Upon scrutinizing the operation executed by the tenant ID and assessing the potential effects associated with canceling it, our technical team successfully terminated the operation at 4:57 AM PST. Subsequently, health checks began to pass successfully, and blocked sessions were cleared.

By 5:11 AM PST, the database had returned to a healthy state. However, ongoing monitoring was maintained to ensure the successful processing of the backlog. At 6:26 AM PST, following successful health checks, we reached out to our affected customers to verify the resolution of the incident. Upon confirmation, the incident was considered resolved.

Root Cause

The issue originated from an operation initiated by one of the tenant IDs that did not complete as expected, resulting in a buildup of backlog of subsequent inventory data in the database.

Remediation Actions

  1. Identification and Termination: A comprehensive investigation identified an incomplete operation initiated by a tenant ID, leading to a successful termination at 4:57 AM PST.
  2. Ongoing Monitoring: Continuous monitoring was maintained to ensure the smooth processing of the backlog and prevent recurrence.
  3. Verification with Customers: At 6:26 AM PST, following successful health checks, we reached out to our affected customers to verify the resolution of the incident.

Future Preventative Measures

  1. Proactive Enhancement of Inventory Import Architecture: We acknowledge the identified issue that prompted our focus on enhancement to our inventory import architecture. Consequently, we have recently implemented a change to the cloud, transitioning to a new queue and ensuring that one tenant's operations do not impede others. This change is aimed at significantly alleviating the identified issue.
  2. Enhanced Alerting Strategy for Monitoring: While we currently have monitoring in place, we recognize the need for an effective alerting mechanism. We are committed to revising and adapting our monitoring and alerting strategies to proactively address this concern.
Posted Jan 29, 2024 - 09:52 PST

Resolved

This incident has been resolved.
Posted Nov 24, 2023 - 06:34 PST

Monitoring

Our technical team has taken the required steps to rectify the issue. Our health checks reflect positive outcomes, showing a reduction in the backlog. We will continue to monitor the situation and will keep you updated on any further developments.
Posted Nov 24, 2023 - 05:31 PST

Investigating

Incident Description: We've been notified of customers encountering difficulties when accessing inventory data on the IT Asset Management platform. This could lead to delays in inventory data for some customers, specifically affecting the EU region, with other regions remaining unaffected.

Priority: P2

Restoration Activity: Our technical teams are actively involved and are evaluating the situation. Additionally, we are exploring potential solutions to rectify the issue as quickly as possible. We sincerely apologize for any inconvenience this may have caused.
Posted Nov 24, 2023 - 05:15 PST
This incident affected: Flexera One - IT Asset Management - Europe (IT Asset Management - EU Inventory Upload).