Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 10, 2025 - 18:00 PDT
Scheduled
Flexera will be upgrading Flexera One - IT Asset Management to version 2024R2.2 in the North American Production environment which will result in downtime during a portion of the maintenance window below:
UTC: March 11 01:00 AM - March 11 03:00 AM PDT: March 10 06:00 PM - March 10 08:00 PM CEST: March 11 02:00 AM - March 11 04:00 AM AEST: March 11 12:00 PM - March 11 02:00 PM
Information about new features and other changes is available at https://docs.flexera.com. Select the 'Flexera One' product and open 'IT Asset Management - Features by Release'.
Posted Mar 05, 2025 - 17:08 PST
This scheduled maintenance affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Beacon Communication, IT Asset Management - US Inventory Upload, IT Asset Management - US Login Page, IT Asset Management - US Batch Processing System, IT Asset Management - US Business Reporting).