Flexera One IT Asset Management - NA - Batch Job Processing Delays

Incident Report for Flexera System Status Dashboard

Resolved

Our technical team has confirmed that batch processing has recovered and is operating as expected. Earlier delays have been addressed, and queued work is now processing normally. We will keep monitoring the environment to ensure stability, and this incident is now resolved.
Posted Jun 04, 2026 - 11:58 PDT

Update

Processing activity continues to improve, and backlog levels are steadily decreasing. Our teams remain in a monitoring phase while the remaining queued work is processed and are continuing to track processing rates and queue volumes to validate sustained recovery.

We will provide further updates as more information becomes available.
Posted Jun 04, 2026 - 00:45 PDT

Monitoring

Our technical team has added processing capacity to improve batch processing throughput and reduce the remaining backlog. Additional processing capacity remains in place and is helping queued work continue to process. Processing activity has improved, and the backlog is continuing to decrease. The team is keeping the incident in a monitoring state while the remaining queued work clears and will continue tracking throughput and queue levels to confirm full recovery.
Posted Jun 03, 2026 - 19:52 PDT

Update

Our technical team is continuing recovery work to restore expected batch processing levels. Cleanup activities have been completed to reduce the current queue, and processing throughput is now improving. The team is continuing to monitor progress while recovery efforts remain in progress.
Posted Jun 03, 2026 - 13:46 PDT

Identified

Our technical team is continuing recovery work to restore expected batch processing levels. Additional processing capacity has been added to help reduce the current queue, and the team is continuing to review how queued jobs are being distributed for processing to improve overall throughput. Recovery efforts remain in progress, and we will continue monitoring the environment while work continues.
Posted Jun 03, 2026 - 11:22 PDT

Investigating

Incident Description: We are investigating an issue affecting batch job processing for Flexera One IT Asset Management in the North America region.

As a result, customers may experience delays in the completion of scheduled or queued batch processing jobs.

Priority: P2

Restoration Activity: Our technical team is actively working to restore expected batch processing levels. Recovery actions are underway to increase processing capacity, reduce the current queue, and improve batch job processing throughput. We will continue to monitor progress and provide updates as recovery work continues.
Posted Jun 03, 2026 - 09:00 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Batch Processing System).