Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 20, 2025 - 02:00 PST
Scheduled
Our cloud service provider will be conducting maintenance on it's data warehouse clusters across all three production regions: US‑East‑1, EU‑Central‑1, and APAC (AP‑Southeast‑2).
Dates/Times: PST : Dec 20th 02:00 AM – 02:30 AM UTC : Dec 20th 10:00 AM – 10:30 AM IST : Dec 20th 03:30 PM – 04:00 PM AEST : Dec 20th 09:00 PM – 09:30 PM
Impact: During this window, certain backend data services may be temporarily unavailable. There is no direct UI impact expected, but backend services that depend on data warehouse may experience: -Delayed data processing -Slower or queued ETL/ELT pipelines -Temporary lag in data freshness across downstream systems
Impacted Services: Data Processing Pipelines (Shard3 & Shard4 dependent flows) Analytics / Reporting Jobs querying data warehouse Backend workflows relying on the above mentioned production environments.
Posted Dec 19, 2025 - 01:06 PST
This scheduled maintenance affected: Flexera One - IT Asset Management - North America (IT Asset Management - US SaaS Manager), Flexera One - IT Asset Management - APAC (IT Asset Management - APAC SaaS Manager), and Flexera One - IT Asset Management - Europe (IT Asset Management - EU SaaS Manager).