Following a period of monitoring, services have remained stable and no further issues have been observed.
This incident is now considered resolved.
Posted Aug 11, 2026 - 13:26 PDT
Monitoring
The configuration changes have been deployed, and the affected service components are now operating with the intended resource configuration. Our technical teams have observed recovery of the impacted Cloud Cost Optimization (CCO) functionality in the North America region and are performing final validation to confirm service stability.
We will continue to monitor the environment closely and provide a further update once validation activities are complete.
Posted Aug 11, 2026 - 11:08 PDT
Identified
Our investigation has identified the issue affecting certain Cloud Cost Optimization (CCO) functionality in the North America region. Following a recent service migration, some application components were not operating with the expected resource configuration, resulting in certain requests failing to complete and impacted pages remaining in a continuous loading state.
Our technical teams have implemented configuration changes to restore the appropriate resource allocation for the affected services and are currently deploying those changes. We are monitoring recovery and validating service functionality as the update takes effect.
We will provide additional updates as progress continues.
Posted Aug 11, 2026 - 10:48 PDT
Investigating
Incident Description: We are investigating an issue affecting Cloud Cost Optimization (CCO) services in the North America (NAM) region. Customers may experience pages failing to load, prolonged loading behavior, or difficulty accessing certain Cloud Cost Optimization functionality within Flexera One.
Priority: P2
Restoration Activity: Our technical teams are actively investigating the issue and working to restore normal service. Current efforts are focused on identifying the cause of the degradation and validating corrective actions. We will provide additional updates as more information becomes available.
Posted Aug 11, 2026 - 10:26 PDT
This incident affected: Flexera One - Cloud Management - North America (Cloud Cost Optimization - US).