Snow Atlas - Australia Southeast, East US2 & West Europe Region - Inventory Data Not Loading

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Snow Atlas - Australia Southeast (ASE), East US2 & West Europe - Inventory Data Not Loading

Timeframe:  January 29, 2025, 2:42 PM PST to January 31, 2025, 10:10 AM PST

Incident Summary

 

On January 29, 2025, at 2:42 PM PST, our monitoring systems detected an issue affecting inventory data availability for Snow Atlas customers in the Australia Southeast, East US2, and West Europe regions. While the platform itself remained accessible, affected customers reported that upon logging into their tenants, the Snowboard appeared blank, and the "Search for Computers" page displayed no data. Attempts to retrieve inventory data resulted in a "No information available" error.

Our technical teams were promptly engaged and suspected that the issue was caused by a recent deployment. Initial investigations confirmed that all infrastructure services were running as expected, ruling out infrastructure-related failures. An attempt was made to restart the service for one affected customer, but this did not resolve the issue.

To mitigate the impact, our teams migrated the database for the affected customers while continuing to work on a permanent fix. By January 30, 2025, at 4:18 AM PST, the issue was resolved for most customers. However, a configuration issue was identified for a subset of customers, preventing the restoration process. After updating the configuration settings, the issue was fully resolved by January 31, 2025, at 10:10 AM PST.

Root Cause

 

The issue was instigated by a recent deployment that inadvertently disrupted inventory data availability for affected customers. While the platform remained operational, the deployment introduced a misconfiguration that prevented inventory data from being displayed correctly. Additionally, a configuration discrepancy for certain customers further delayed the complete resolution.

Remediation Actions

 

·        Database Migration: The affected customers’ databases were migrated to restore access to inventory data while further investigation into the root cause continued.

·        Service Restart Attempt: A restart of the service was attempted as part of troubleshooting, but this action did not resolve the issue.

·        Configuration Correction: A configuration discrepancy impacting certain customers was identified and updated to restore full functionality.

Enhanced System Monitoring: Continuous monitoring was performed post-mitigation to ensure service stability and prevent recurrence

Future Preventative Measures

 

 

·        Thorough Root Cause Analysis: Conduct an in-depth root cause analysis to identify the exact failure points and determine preventive measures to avoid similar incidents in the future.

·        Deployment Validation Enhancements: Strengthen pre-deployment validation processes to minimize the risk of misconfigurations.

·        Automated Configuration Verification: Implement automated validation mechanisms to ensure configurations are applied correctly across all customer environments before deployment.

·        Expanded Monitoring and Alerting: Enhance real-time monitoring and alerting capabilities to proactively detect and diagnose inventory data inconsistencies.

Posted Feb 12, 2025 - 04:45 PST

Resolved

This incident has been resolved.
Posted Jan 30, 2025 - 04:20 PST

Monitoring

Our teams identified an issue with the database and have taken corrective actions. We are currently monitoring the results.
Posted Jan 30, 2025 - 01:37 PST

Identified

Our teams were able to isolate the cause of the issue and are working to implement a fix.
Posted Jan 30, 2025 - 00:57 PST

Update

Our teams are actively investigating the root cause and are working to implement a solution. We will share further updates as soon as they become available.
Posted Jan 30, 2025 - 00:20 PST

Update

Our technical team suspects the issue is related to a recent code change. We have engaged additional SMEs to assist with the investigation.
Posted Jan 29, 2025 - 16:46 PST

Update

Our technical team attempted a service restart, but the issue persists. We are continuing to investigate further.
Posted Jan 29, 2025 - 15:58 PST

Investigating

Incident Description: We are currently investigating an issue affecting inventory data availability in the Australia Southeast, East US2, and West Europe regions for Snow Atlas. Customers may experience a blank Snowboard upon login and see no data in the "Search for Computers" page. Additionally, attempts to retrieve inventory data may result in a "No information available" error. While the platform remains accessible, inventory data is not displaying as expected.

Priority: P2

Restoration Activity: Our technical team is actively working to determine the root cause and restore inventory data visibility. We will provide further updates as more information becomes available.
Posted Jan 29, 2025 - 15:08 PST
This incident affected: Snow Atlas (Snow Atlas - America, Snow Atlas - Australia, Snow Atlas - Europe, Snow Atlas API - Australia, Snow Atlas API - America, Snow Atlas API - Europe).