CloudCheckr – All Regions – Inventory and Cost Collection Delays

Incident Report for Flexera System Status Dashboard

Postmortem

Description: CloudCheckr – All Regions – Inventory and Cost Collection Delays

Timeframe: April 1, 2026, 1:00 PM PDT – April 6, 2026, 8:00 PM PDT

Incident Summary

On April 1, 2026, at approximately 1:00 PM PDT, an issue was identified affecting inventory and cost collection within CloudCheckr across all regions. During this period, some customers experienced delays in inventory and cost data collection.

During the investigation, technical teams confirmed impact across US, EU, AU, GOV, and HSE regions. The issue was linked to service disruptions affecting an external cloud service provider in Middle East regions. As the incident progressed, technical teams confirmed that the issue was causing failures in discovery workflows and was also impacting billing and invoicing. For customers with usage in the affected regions, collection workflows were delayed while processing waited on timeouts before moving on.

Technical teams monitored the environment closely while developing and validating a mitigation. A product-side mitigation was then deployed across all CloudCheckr regions to bypass the affected Middle East region on a per-customer basis when communication with that region failed. Following completion of the deployments, technical teams continued monitoring and validating service behavior across regions.

By April 6, 2026, at approximately 8:00 PM PDT, recovery had been confirmed, with no remaining concerns at that time regarding data processing, billing, or invoicing, and the incident was considered resolved.

Root Cause
The incident was caused by service disruptions affecting an external cloud service provider in Middle East regions. As a result, CloudCheckr collection workflows encountered timeouts when processing customers with usage in the affected regions, which led to delays in inventory and cost data collection and also impacted billing and invoicing.

Remediation Actions
The following actions were taken during the incident response:

  1. Incident Investigation Initiated: Technical teams began investigating delays affecting inventory and cost collection across CloudCheckr regions.
  2. External Service Disruption Identified: The issue was linked to service disruptions affecting an external cloud service provider in Middle East regions.
  3. Impact Assessment Performed: Technical teams assessed the effect on collection workflows, including discovery, billing, and invoicing.
  4. Monitoring Continued: Teams continued to monitor service behavior and customer impact while evaluating mitigation options.
  5. Product-Side Mitigation Deployed: A mitigation was deployed across CloudCheckr regions to bypass the affected Middle East region on a per-customer basis when communication with that region failed.
  6. Recovery Validated: Following deployment, technical teams monitored the environment and confirmed recovery across all regions before resolving the incident.

Future Preventative Measures

• Resilient Regional Collection Handling: We will further strengthen CloudCheckr’s collection logic to reduce dependency on a single affected region during external service disruptions. This includes improving how collection workflows detect repeated regional communication failures and continue processing in a way that helps minimize delays to inventory, cost, billing, and invoicing activities across other unaffected regions.

Posted Apr 21, 2026 - 20:42 PDT

Resolved

Following the fix deployment across all CloudCheckr regions, the environment has remained stable and technical team validation has confirmed recovery. This incident is now considered resolved.
Posted Apr 07, 2026 - 14:36 PDT

Monitoring

Fix deployment has been successfully completed across all regions, and our teams are actively monitoring the services to ensure continued stability and expected performance.
Posted Apr 06, 2026 - 22:42 PDT

Update

Our technical teams continue to work on the issue affecting CloudCheckr inventory and cost collection across all regions. A product-side mitigation is now being deployed across CloudCheckr regions to help address the ongoing impact on collection workflows when communication with the affected external region fails.

Testing is being finalized, and deployments are in progress across CloudCheckr regions. We will continue to provide updates as more information becomes available.
Posted Apr 06, 2026 - 11:04 PDT

Identified

Our technical teams continue to monitor the issue affecting CloudCheckr inventory and cost collection across all regions and are assessing the potential for broader impact over the next couple of days as billing-related processing activity increases. We will continue to provide updates as more information becomes available.
Posted Apr 02, 2026 - 17:12 PDT

Investigating

Incident Description: We have identified an issue affecting CloudCheckr inventory and cost collection across all regions. As a result, some customers may experience delays in inventory and cost data collection.

Priority: P2

Restoration Activity: The disruption has been linked to service issues affecting our service provider. Our technical teams are monitoring the situation closely, assessing any downstream impact, and will provide further updates as more information becomes available.
Posted Apr 02, 2026 - 13:50 PDT
This incident affected: CloudCheckr (CloudCheckr US region, CloudCheckr - EU (European Region), CloudCheckr - AU (Australia & New Zealand region), CloudCheckr GOV region, CloudCheckr Federal).