Flexera - Ticketing service - Degraded performance for emails

Incident Report for Flexera System Status Dashboard

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 01:56 PDT

Investigating

Issue Description: We are currently investigating a service degradation affecting the ITSM tool email system that may have prevented some customers from receiving email updates from us.

Priority: P3

Restoration Activity: Our technical teams are actively investigating and have identified the likely root cause. Work is underway to implement a fix, and further updates will be provided as progress continues.
Posted Aug 15, 2025 - 05:14 PDT