Backend services have stabilized, and the platform is operating as expected with no further outstanding concerns. This incident is now resolved.
Posted Aug 07, 2025 - 13:27 PDT
Monitoring
The disruption was traced to a backend service issue, and corrective actions have been taken to restore functionality. The platform is now operating as expected.
Customer Action: If any non-meta policies remain in a pending state, we recommend manually triggering them using the “Run now” option. Meta parent policies may take additional time to complete automatically.
We will continue to monitor the platform to ensure full recovery.
Posted Aug 07, 2025 - 08:56 PDT
Investigating
Incident Description: We are currently experiencing an issue within the Cloud Cost Optimization (CCO) platform affecting a subset of our customers in the NAM region. While the platform remains accessible, affected customers may experience degraded functionality related to recommendations, bill ingestion, shared costs, cost allocation, and other related services. Users may also encounter “500 – Internal Server Error” messages during these operations.
Priority: P2
Restoration Activity: Our technical team is actively investigating the root cause and working to restore services as quickly as possible. We will continue to share updates as we make progress toward a resolution.
Posted Aug 07, 2025 - 05:33 PDT
This incident affected: Flexera One - Cloud Management - North America (Cloud Cost Optimization - US).