Our teams have completed post-deployment validation and confirmed that service performance has returned to expected levels. Continued monitoring has shown stable platform operation with no further impact observed. Based on these results, this issue is now considered resolved.
Posted Jul 22, 2026 - 09:16 PDT
Monitoring
The hotfix has been successfully deployed, and engineering teams are currently validating its effectiveness. Teams are continuing to monitor platform behaviour and review telemetry to confirm the issue resolution.
Posted Jul 22, 2026 - 08:40 PDT
Update
Our teams continue to work on implementing a hotfix to address the issue . During deployment, the hotfix encountered database conditions that are preventing it from completing successfully.
Our technical teams are actively working to resolve this and are evaluating targeted mitigation actions to allow the hotfix to complete. Once the hotfix has been successfully applied, teams will validate service performance and continue monitoring to confirm recovery. We will provide another update as more information becomes available.
Posted Jul 22, 2026 - 06:38 PDT
Identified
Incident Description: We have identified an issue affecting inventory processing in Flexera One IT Asset Management following the deployment of the 2026 R1.1 release in our US production environment. As a result, some customers may experience degraded performance and intermittent reliability issues when accessing certain areas of the user interface and performing system-related tasks.
Priority: P3
Restoration Activity: Our investigation has determined that the issue is related to a software defect introduced with the 2026 R1.1 release. While the defect had been previously identified and mitigation procedures were incorporated into the deployment process, the automated remediation encountered unexpected execution issues . As a result, technical teams have implemented alternative mitigation measures to reduce customer impact and stabilise system performance.
We continue to actively monitor the environment and apply corrective actions to address the underlying defect and restore normal service operation.
Posted Jul 22, 2026 - 01:25 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Inventory Upload).