Scheduled Maintenance – Snow Atlas – Australia Southeast Region

Scheduled for Nov 5, 10:00 - 12:00 PST

Update

We will be undergoing scheduled maintenance during this time.
Posted Nov 03, 2025 - 01:38 PST

Scheduled

Flexera will be performing scheduled platform maintenance on the Snow Atlas production environment in the Australia Southeast Region.
Impact: Users may experience intermittent access disruptions during this time as we perform these updates.
Reason: Upgrading critical software version due end of life support.

Australia Southeast Region:
Dates/Times:
PST: November 5th, 10:00 AM to 12:00 PM
CET: November 5th, 7:00 PM to 9:00 PM
IST: November 5th, 11:30 PM to November 6th 1:30 AM
AEDT: November 6th, 05:00 AM to 07:00 AM
Posted Nov 03, 2025 - 01:36 PST
This scheduled maintenance affects: Snow Atlas (Snow Atlas - Australia, Snow Atlas API - Australia).