Flexera One UI – APAC, EU & NA – Intermittent Login Disruption

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One UI – APAC, EU & NA – Potential Login Disruption

Timeframe:  April 29, 2025, 13:00 PST to April 29, 2025, 14:55 PST

Incident Summary

On Tuesday, April 29, 2025, at approximately 13:00 PST, our engineering teams began investigating reports of intermittent login failures affecting the Flexera One UI across the APAC, EU, and NA production regions. Users attempting to log in experienced incomplete authentication flows, resulting in an inability to access Flexera One services, including IT Asset Management (ITAM), IT Visibility (ITV), and other related applications. The issue was confirmed through internal monitoring, which detected elevated authentication failure rates, as well as customer reports indicating widespread access disruptions. The incident persisted for approximately 1 hour and 55 minutes, during which time customers were unable to perform key operations within the platform. The disruption impacted user experience across all major regions until full service was restored. The suspected configuration change was reverted to its previous stable state to mitigate the impact.

Root Cause

The root cause was traced to a recent configuration update deployed earlier in the day that altered session handling behavior in the authentication layer of the Flexera One platform. This update introduced an unexpected conflict in how user sessions were processed. As a result, valid login attempts intermittently failed due to premature session expiration or misrouted authentication requests.

Although the change passed standard functional tests in lower environments, it was not subjected to the integration tests that would have replicated this edge case production-scale activity. This led to the oversight of the issue prior to deployment. And the issue was declared as restored post validations and customer confirmation At 14:55 PST.

Remediation Actions

·        Rollback of Configuration Update: The suspected configuration change was reverted to its previous stable state to halt further impact.

·        Service Health Checks and Restarts: Authentication services were restarted across impacted regions to ensure clean session state and refresh the service environment.

·        Customer Communication: Customers were advised to clear browser cache and session data to eliminate residual client-side artifacts that may have persisted post-rollback.

·        Validation and Monitoring: Engineering teams closely monitored login success rates and customer feedback. By 14:40 PST, metrics indicated full recovery. Final validation was received from customers confirming resolution.

·        Restore Declaration: At 14:55 PST, the incident was declared resolved, with login functionality stable across all regions.

Future Preventative Measures

·        Enhanced Pre-Deployment Testing: Incorporate stress and load testing as part of the QA process for all authentication and session-related changes.

·        Improved Monitoring and Alerting: Strengthen monitoring of authentication workflows with region-specific metrics and alert thresholds for early detection of login anomalies.

·        Postmortem Review and Training: Conduct a cross-functional review with engineering, QA, and operations to identify gaps in the deployment pipeline and reinforce best practices.

Posted May 07, 2025 - 02:26 PDT

Resolved

The incident has been resolved, with login functionality stable across all regions and monitoring continuing to show normal behavior.
Posted Apr 29, 2025 - 15:38 PDT

Identified

A recent update that may have contributed to the login issues has been reverted as a precaution. Customers encountering difficulties are advised to clear their browser cache and data and retry accessing the Flexera One login page.

Following these actions, system health checks are now indicating normal login behavior. We are continuing to monitor closely to confirm sustained recovery.
Posted Apr 29, 2025 - 15:06 PDT

Update

We are continuing to monitor a potential intermittent login issue that may be affecting some customers across multiple regions. Our teams are actively investigating, including reviewing potential UI and network-related factors. While no root cause has been identified yet, we are working closely with affected customers to gather additional details that may help isolate contributing factors.
Posted Apr 29, 2025 - 14:00 PDT

Investigating

Incident Description: We are currently investigating a potential intermittent issue that may affect access to the Flexera One UI across multiple production regions (APAC, EU, NA). Some customers may experience difficulty logging into the platform, which could impact access to all Flexera One applications. Our teams are actively working to determine the cause and assess the scope of the situation.

Priority: P2

Restoration Activity: Technical teams are engaged and actively investigating the potential issue. We are closely monitoring the environment and continuing to evaluate possible contributing factors. Further updates will be provided as more information becomes available.
Posted Apr 29, 2025 - 13:13 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Beacon Communication, IT Asset Management - US Inventory Upload, IT Asset Management - US Login Page, IT Asset Management - US Batch Processing System, IT Asset Management - US Business Reporting, IT Asset Management - US SaaS Manager, IT Asset Management - US Restful APIs), Flexera One - IT Asset Management - Europe (IT Asset Management - EU Beacon Communication, IT Asset Management - EU Inventory Upload, IT Asset Management - EU Login Page, IT Asset Management - EU Batch Processing System, IT Asset Management - EU Business Reporting, IT Asset Management - EU SaaS Manager, IT Asset Management - EU Restful APIs), Flexera One - IT Visibility - North America (IT Visibility US), Flexera One - IT Visibility - Europe (IT Visibility EU), Flexera One - Cloud Management - Europe (Cloud Cost Optimization - EU), Flexera One – APIs – North America (api.flexera.com), Flexera One – APIs – Europe (api.flexera.eu), Flexera One - IT Asset Management - APAC (IT Asset Management - APAC Beacon Communication, IT Asset Management - APAC Inventory Upload, IT Asset Management - APAC Login Page, IT Asset Management - APAC Batch Processing System, IT Asset Management - APAC Business Reporting, IT Asset Management - APAC SaaS Manager, IT Asset Management - APAC Restful APIs), Flexera One – APIs – APAC (api.flexera.au), Flexera One - IT Visibility - APAC (IT Visibility - APAC), Flexera One - Cloud Management - APAC (Cloud Cost Optimization - APAC), Flexera One - SBOM Management - North America (SBOM Management API - US, SBOM Management SCA Data Library API - US), Flexera One - Cloud License Management - North America (Cloud License Management - US), Flexera One - Cloud License Management - Europe (Cloud License Management - EU), Flexera One - Cloud License Management - APAC (Cloud License Management - APAC), and Flexera One - Cloud Management - North America (Cloud Cost Optimization - US, Cloudscape).