Saas Manager - APAC - Service degradation affecting access to SaaS manager service

Incident Report for Flexera System Status Dashboard

Resolved

After an extended period of monitoring, our teams have confirmed that the services remain stable. We are officially declaring this incident resolved.
A detailed post-incident report will be published soon, outlining the root cause and preventive measures.
Posted Sep 17, 2025 - 04:41 PDT

Update

We are continuing to monitor for any further issues.
Posted Sep 16, 2025 - 23:24 PDT

Monitoring

Our teams have implemented an immediate fix, and all services are now fully restored. We are continuing a detailed investigation into the root cause and working on a permanent solution to prevent recurrence.
Posted Sep 16, 2025 - 23:24 PDT

Update

Our teams have identified the likely cause of the issue and suspect it may be related to a recent maintenance activity. We are currently evaluating corrective actions to restore services.
Posted Sep 16, 2025 - 22:46 PDT

Investigating

Incident Description:
Our teams have identified a service disruption affecting the SaaS Manager platform in the APAC region. Impacted users may experience difficulties accessing SaaS Manager and associated managed SaaS applications, including encountering error messages during login or usage.

Priority: P1

Restoration activity:
Our technical team is actively working on identifying the root cause and restoring services. Further updates will be provided as we continue our efforts to resolve the incident.
Posted Sep 16, 2025 - 21:13 PDT
This incident affected: Flexera One - IT Asset Management - APAC (IT Asset Management - APAC SaaS Manager).