Flexera One - IT Asset Management - EU & NAM - Multiple inventory imports are failing

Incident Report for Flexera System Status Dashboard

Resolved

Continuous successful imports have been confirmed in the EU and US regions following our recent hotfix. This issue primarily impacted our US and EU customers and has been thoroughly addressed to restore full functionality of inventory imports.

Initially, we assessed a potential impact in the APAC region. However, these cases have been determined to be unrelated to the incident affecting the US and EU regions. We are actively addressing these isolated instances in APAC separately, and there is no broader impact observed in that region.

We will issue a formal post-mortem report in the coming days. This incident is now resolved.
Posted Mar 21, 2025 - 10:39 PDT

Monitoring

Following the recent hotfix deployment, we have observed successful inventory imports for multiple customers who previously encountered issues. We are closely monitoring the situation to ensure consistent performance across all regions.
Posted Mar 20, 2025 - 17:20 PDT

Update

The hotfix has been successfully deployed across all production environments. We are currently monitoring the situation and conducting additional validations to ensure its effectiveness.
Posted Mar 20, 2025 - 08:51 PDT

Update

Our technical teams have completed initial testing of the implemented fix and are now conducting further validations to ensure its effectiveness and stability. Given the complexity of the issue, we are taking a meticulous approach to minimize any potential risks. We remain on track and will continue to provide timely updates as we progress. Thank you for your patience and support as we work toward a resolution.
Posted Mar 19, 2025 - 04:43 PDT

Update

We have identified that the recent inventory import issues are due to a change in the file compression method used by our IT Asset Management (ITAM) system. Older versions of our Beacon software utilize a different compression method, leading to compatibility issues during the import process.​

Our technical teams have implemented a fix, which is currently undergoing rigorous testing to ensure its effectiveness and stability. Given the complexity of the issue, this process is thorough and may span over the next few days. We will continue to provide periodic updates as we make progress. We appreciate your patience and understanding as we work diligently to address this issue.
Posted Mar 18, 2025 - 11:45 PDT

Identified

Incident Description: We are currently addressing an issue impacting inventory imports for IT Asset Management (ITAM) services in the EU & NAM regions. While the system remains accessible, some tenants are experiencing inventory upload failures following the recent 2024 R2.2 Production upgrade.

Priority: P2

Restoration Activity: Our technical teams have identified the root cause and have a workaround in place. They are actively working on a permanent resolution, and we will provide further updates as progress continues.
Posted Mar 18, 2025 - 01:18 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Inventory Upload), Flexera One - IT Asset Management - Europe (IT Asset Management - EU Inventory Upload), and Flexera One - IT Asset Management - APAC (IT Asset Management - APAC Inventory Upload).