Spot Ocean – AWS – Ocean ECS Console Performance Degradation

Incident Report for Flexera System Status Dashboard

Resolved

We have continued to monitor the environment for an extended period and services have remained stable, with no further issues observed.

This incident has been resolved.
Posted Jul 06, 2026 - 09:57 PDT

Monitoring

Our investigation identified that the degradation was related to an AWS service health event impacting the us-east-1 region. AWS has since reported that the issue has been resolved, and we are now seeing signs of recovery on our side, including improved Spot Ocean ECS console performance and successful completion of related AWS workflows.

The production environment appears stable at this time. Our teams will continue monitoring for a short validation period to ensure performance remains stable before marking the incident resolved.
Posted Jul 06, 2026 - 08:11 PDT

Investigating

Incident Description: We are currently investigating degraded performance affecting Spot Ocean ECS for AWS customers. Customers may experience significant slowness or delays when accessing the console or using certain Ocean ECS functionality.

Priority: P2

Restoration Activity: Our technical teams are actively investigating and working to restore normal functionality. We will provide further updates as more information becomes available.
Posted Jul 06, 2026 - 07:19 PDT
This incident affected: Spot (Spot UI).