Spot Ocean AWS-All regions- Degraded performance for interruptions recovery

Incident Report for Flexera System Status Dashboard

Resolved

Our technical team promptly identified the cause of the issue and developed a fix. Once implemented, this fix successfully resolved the issue and restored performance to normal levels.
Posted Jul 16, 2025 - 06:22 PDT

Identified

Incident Description:
We are currently investigating an issue related to degraded performance in the Spot Ocean AWS service during the recovery process from recent interruptions. As a result, some customers may experience slowness or delays in service performance.

Priority: P2

Restoration Activity:
Our teams have identified the root cause and are actively working on implementing a fix. We will continue to provide updates as progress is made and service performance is restored.
Posted Jul 16, 2025 - 05:55 PDT