Flexera One - IT Asset Management - NA - Batch Processing Delays

Incident Report for Flexera System Status Dashboard

Resolved

The backlog has been addressed, and normal batch processing operations have resumed. This incident has been resolved.
Posted Feb 14, 2025 - 14:45 PST

Update

We are making progress in processing tasks, especially those that accumulated substantial data backlog from earlier issues. We are now efficiently handling newer submissions.

Although there is still a volume of tasks pending, our systems are operating at increased capacity, processing multiple tasks concurrently to reduce the backlog swiftly.

We will continue to oversee the developments and provide updates on the progress.
Posted Feb 14, 2025 - 12:45 PST

Update

We have successfully cleared all older backlog tasks, and only recent submissions are currently being processed. This has led to several tasks being completed successfully. However, we are observing a slowdown in the processing of some larger tasks and are actively investigating potential causes to prevent any impact on our services.

Investigations into this matter are underway to identify and resolve any underlying problems. We will continue to monitor the situation and take necessary actions to maintain system efficiency.
Posted Feb 14, 2025 - 10:10 PST

Update

We continue to make substantial progress, significantly reducing the number of outstanding tasks. Currently, only a small number of tasks from previous days remain, with all of today's tasks being processed efficiently.

Additionally, we are addressing a backlog of routine system updates which do not impact the primary operations of our platform. Our team is actively managing these tasks to ensure they do not cause any disruptions to service.
Posted Feb 14, 2025 - 08:44 PST

Update

The batch processor has continued to make steady progress in addressing a significant backlog of tasks. We have successfully moved through initial processing stages and are now handling subsequent data management operations. Our technical team is actively monitoring the situation and will continue to conduct periodic reviews to ensure all processes are completed efficiently.
Posted Feb 13, 2025 - 18:42 PST

Update

The system continues to address the backlog of high-volume tasks. Progress is being made, particularly with significant operations that had slowed batch processing speeds. We are observing improvements as these key tasks near completion.

Our team is closely monitoring all processes to ensure their successful and timely conclusion. We will keep you updated on further developments and thank you for your continued patience.
Posted Feb 13, 2025 - 14:01 PST

Update

The system is currently executing several high-volume database processes, including significant key operations. Once these substantial tasks are completed, we anticipate that the remaining batch processes will resume normal progress.

We are closely monitoring the situation to ensure successful completion.
Posted Feb 13, 2025 - 09:59 PST

Update

Following the 2024 R2.1 upgrade last night, our team is actively addressing residual batch tasks that have accumulated post-upgrade. We have observed successful license reconciliations since yesterday and are ensuring that all tenant reconciliations are proceeding as expected.

We will continue to monitor the situation and provide updates as we make progress.
Posted Feb 13, 2025 - 08:11 PST

Update

Our technical teams are actively monitoring the situation and anticipate that the upcoming 2024 R2.1 upgrade scheduled for tonight will result in the termination of the stalled processes, which is expected to alleviate the current backlog.

We will continue to monitor the system's performance following the upgrade to ensure that batch processing tasks return to normal operation. Further updates will be provided as necessary.
Posted Feb 12, 2025 - 11:12 PST

Identified

Incident Description: Following the resolution of yesterday's reconciliation issue, we are now investigating delays in batch processing tasks in the NA environment for Flexera One IT Asset Management (ITAM). Customers may experience delays in data updates, including reconciliation and other scheduled processes.

Priority: P2

Restoration Activity: While reconciliation functionality was successfully restored and verified, subsequent batch processing delays have emerged due to a backlog of tasks in the system. The reconciliation process was temporarily halted during the incident, and the resulting task volume is now contributing to the current delays.

Our teams are actively clearing the backlog, monitoring task performance, and addressing any stalled tasks. We are also reviewing the scheduler services and related infrastructure to ensure smooth task execution moving forward.
Posted Feb 12, 2025 - 10:33 PST
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Batch Processing System).