Flexera One – NA – SaaS Manager is Currently Unavailable
Incident Report for Flexera System Status Dashboard
Postmortem

Description: Flexera One – NA – SaaS Manager was Unavailable

Timeframe: December 5th, 3:12 AM to December 5th, 5:41 AM PST

Incident Summary

On December 5th, at 3:12 AM PST, during the routine health checks, technical staff found that the SaaS Manager application was unavailable in the NA region. As a result, Customers may have received errors while trying to access Managed SaaS Applications. EU was not impacted by this outage.

Additional SMEs were engaged to assist with the investigation. Upon further investigation, technical staff observed resource contention issues caused by high CPU utilization in multiple nodes.

To remediate the issue, at 5:41 AM PST, staff rebooted the impacted nodes. Health checks and monitoring confirmed that the service had returned to its stable state following which the incident was declared resolved.

Root Cause

• Technical staff found that service degradation was a result of resource contention issues caused by high CPU utilization in multiple nodes
• Investigations are ongoing in the staging environment to detect the contributing factor(s) causing the high CPU utilization in the environment

Corrective Action

  1. Technical staff restarted the impacted nodes to remediate the issue
  2. We have deployed a change to production to resize the nodes to larger instances
  3. Technical staff have been tasked to monitor the services in the staging environment to identify the contributing factors and implement a long-term solution in production
Posted Dec 14, 2022 - 12:17 PST

Resolved
We have rebooted the impacted services. Health checks have also confirmed that the Managed Applications are accessible now. This incident has been resolved.
Posted Dec 05, 2022 - 05:46 PST
Update
The investigation is still ongoing. Technical teams are analyzing all the components to isolate and identify the issue.
Posted Dec 05, 2022 - 05:10 PST
Investigating
Incident Description: We are currently experiencing issues with the SaaS Manager application in the NA region. Customers may receive an error while trying to access Managed SaaS Applications.

Error “An unexpected error occurred while loading managed applications”

Priority: P1

Restoration activity: Technical teams have been engaged and are currently investigating.
Posted Dec 05, 2022 - 03:48 PST
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US SaaS Manager).