Flexera One - IT Asset management - APAC - Data loading failures/slowness

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One - IT Asset management - APAC - Data loading failures/slowness

Timeframe: August 4, 2026, 4:04 AM PDT to August 4, 2026, 4:25 AM PDT

Incident Summary

On Tuesday, August 4, 2026, our teams identified an issue affecting a subset of customers in the APAC Production environment. During the incident, some customers experienced intermittent application slowness, temporary unresponsiveness, and failures when loading data within Flexera One IT Asset Management.

Our technical teams investigated the issue and determined that an unexpected database resource exhaustion event affected the production environment. The condition resulted in temporary performance degradation for a subset of customer tenants.

The database condition resolved automatically after approximately 20 minutes, and application performance returned to normal without requiring direct engineering intervention. Our teams continued to monitor the environment following recovery and confirmed that affected services were operating normally with no ongoing customer impact..

Root Cause

  • Unexpected Database Resource Exhaustion: A temporary increase in database resource consumption exhausted the available temporary database storage capacity used by the production database cluster.
  • High Resource-Consuming Queries: It was identified that specific unexpected query run manually by a user that consumed significant amounts of temporary database resources, resulting in a temporary resource exhaustion condition.
  • Application Performance Impact: The resource exhaustion affected database operations and resulted in intermittent application slowness, unresponsiveness, and data loading failures for a subset of customers.

Remediation Actions

  • Automatic Service Recovery: The database resource condition cleared automatically, allowing application services to return to normal operation.
  • Service Monitoring: Teams monitored the environment following recovery and confirmed that services remained stable.
  • Incident Analysis: Engineering teams reviewed the database activity and resource utilization associated with the event to identify the contributing queries and understand the behaviour.

Future Preventative Measures

  • Resource Governance: Evaluate additional SQL Server resource governance controls to reduce the potential impact of high-resource database queries.
  • Alert Response Improvements: Review alert handling procedures to improve detection, assessment, and response to similar database resource conditions.
  • Operational Improvements: The query has been reviewed by our technical teams and measure have been put in place to avoid a similar scenario in the future.
Posted Aug 21, 2026 - 02:05 PDT

Resolved

Incident Description: Our teams identified a service disruption affecting a subset of Flexera One IT Asset Management (ITAM) customers in the APAC Production environment from 4 August 2026, 04:04 AM PDT to 04:25 AM PDT . During the affected period, a subset of our customers experienced intermittent slowness, service unresponsiveness, or data loading failures within the platform.

Priority: P2

Restoration Activity: Our technical teams investigated the issue and determined that an unexpected database resource exhaustion condition occurred during the affected period. The condition subsequently self-corrected, allowing affected services to recover and return to normal operation. Post-incident validation confirmed that platform operations are performing as expected. We are conducting a detailed review of the incident and evaluating additional safeguards, capacity controls, and monitoring improvements to further reduce the likelihood of similar events in the future.
Posted Aug 05, 2026 - 01:28 PDT
This incident affected: Flexera One - IT Asset Management - APAC (IT Asset Management - APAC Inventory Upload, IT Asset Management - APAC Batch Processing System).