Flexera One - IT Asset Management - US- Application Server Connectivity Issues

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One – IT Asset Management - NA - Slow Load Times and Errors

Timeframe: September 22nd, 2024, 11:00 PM to September 22nd, 2024, 11:20 PM PDT

Incident Summary

On Sunday, September 22nd, 2024, at approximately 11:00 PM PDT, we experienced an issue affecting the IT Asset Management (ITAM) platform in the NA region. During this period, customers may have encountered errors and slow performance when trying to access ITAM. The incident was isolated to the NA region, with no impact on other regions.

The issue was triggered by an unexpected surge in system resource usage during a routine background process, which caused database contention. This resulted in temporary connectivity issues between the application servers and the platform's core processing components.

Our technical team promptly identified the root cause and monitored the system as the process concluded. By 11:20 PM PDT, the system self-restored, and normal functionality returned to the platform.

Following additional validations and internal health checks, we confirmed that the platform was fully operational. The incident was officially declared resolved shortly after all services were confirmed stable.

Root Cause

Primary Root Cause
The incident was caused by excessive resource usage during a routine background process. This led to temporary connectivity issues, affecting customer access to ITAM.

Contributing Factors
• Resource Contention: The background process consumed more resources than anticipated, leading to delays and degraded performance.
• Process Overlap: Multiple background tasks were running simultaneously, contributing to resource strain that impacted the platform’s performance.

Remediation Actions

  1. Resource Management: After identifying the resource-intensive background process, our technical team monitored the system as the process concluded, restoring normal platform performance.
  2. Health Checks and Monitoring: Internal health checks were conducted immediately after the issue was resolved, followed by extended monitoring to ensure platform stability.
  3. Customer Communication: Affected customers were contacted to confirm that the ITAM platform was fully operational and performing as expected.

Future Preventative Measures

  1. Enhanced Resource Management for Background Processes: We will optimize the execution and scheduling of resource-intensive background processes to prevent system resource overuse. This will ensure balanced resource allocation and maintain stable platform performance, even during peak operations.
  2. Infrastructure Upgrade: We are in the process of upgrading our system infrastructure, which will improve performance and resource handling. This upgrade will be gradually deployed across all regions over the coming months.
  3. Conflict Avoidance Mechanism: We will implement updates to prevent critical processes from competing for system resources, ensuring smooth operation during peak loads.
  4. Proactive Monitoring: We will enhance our monitoring systems to better track resource usage during background processes, ensuring issues are detected and mitigated before they affect platform stability.
Posted Oct 17, 2024 - 14:30 PDT

Resolved

This incident has been resolved.
Posted Sep 23, 2024 - 02:17 PDT

Monitoring

Incident Description:
We are currently investigating an issue affecting the IT Asset Management (ITAM) platform in the NA region. As a result, some customers may experience issues while connecting to app servers and and certain UI components may fail to load.

Priority: P1

Restoration activity:
Our teams swiftly identified the root cause of the issue and implemented the necessary restorative measures to address it. We are closely monitoring the platform to ensure stability and to detect any potential recurrences.
Posted Sep 22, 2024 - 23:33 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Beacon Communication, IT Asset Management - US Inventory Upload, IT Asset Management - US Login Page, IT Asset Management - US Batch Processing System, IT Asset Management - US Business Reporting, IT Asset Management - US Restful APIs).