Inventory processing performance has been restored across the platform. Additional measures have been taken to ensure continued processing efficiency where needed.
This incident is now considered resolved, and we will continue to monitor the environment to ensure ongoing stability.
Posted Mar 28, 2025 - 09:36 PDT
Update
Inventory processing performance continues to trend in a positive direction following the changes implemented yesterday. We plan to reassess progress in the morning after the overnight imports have completed and will provide further updates as needed.
Posted Mar 27, 2025 - 21:02 PDT
Update
Inventory processing performance continues to improve, with overall progress trending in the right direction. Additional infrastructure adjustments were made earlier to support processing throughput. Monitoring remains in place as we continue working to ensure consistent performance across the platform.
Posted Mar 27, 2025 - 12:11 PDT
Monitoring
A significant portion of the inventory data backlog has now been cleared, and the platform is progressing steadily toward full resolution. Our teams continue to monitor performance and will provide further updates as we move closer to full recovery.
Posted Mar 26, 2025 - 20:24 PDT
Update
We have continued tuning infrastructure allocations to improve processing throughput for tenants with higher inventory volumes. Recent adjustments have contributed to a meaningful reduction in backlog across several environments. In some cases, additional capacity has been added to help stabilize processing rates and support further progress.
Our teams are closely monitoring platform performance and will continue to implement optimizations as needed to ensure timely inventory data updates.
Posted Mar 26, 2025 - 13:02 PDT
Update
We have made adjustments within the platform to optimize processing for tenants with higher inventory volumes. Early indicators suggest that these changes are beginning to reduce the backlog. Our teams are continuing to monitor performance closely and will evaluate further tuning as needed to ensure continued progress.
Posted Mar 25, 2025 - 22:40 PDT
Update
We are preparing additional enhancements to optimize how inventory processing is prioritized across the platform. These improvements are intended to dynamically allocate resources based on backlog size, helping to improve responsiveness for tenants with higher volumes. Implementation planning is underway, and we will continue to provide updates as progress continues.
Posted Mar 25, 2025 - 20:21 PDT
Update
We have implemented additional infrastructure changes to improve inventory processing throughput. These changes build on previous efforts and are designed to accelerate progress in reducing the existing backlog. Monitoring remains ongoing, and we continue to evaluate further adjustments as needed to ensure consistent and timely inventory data updates across the platform.
Posted Mar 25, 2025 - 15:34 PDT
Update
We have implemented infrastructure optimizations to improve inventory processing throughput. Early indicators show increased processing rates, and our teams are actively monitoring the impact of these changes. Additional measures are being evaluated to further reduce the backlog and ensure timely reflection of inventory data across the platform.
Posted Mar 25, 2025 - 14:30 PDT
Investigating
Incident Description: We are currently investigating an inventory processing backlog affecting IT Asset Management (ITAM) services in the North America region. As a result, customers may experience delays in the reflection of the most recent inventory data within the platform.
Priority: P2
Restoration Activity: Our teams are actively reviewing processing behavior and evaluating targeted remediation steps to reduce the backlog and ensure timely inventory updates. We are continuing to assess options to mitigate impact and will share further updates as progress is made.
Posted Mar 25, 2025 - 13:21 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Inventory Upload).