Flexera One – Saas Manager – EU – Scheduled Integration Tasks were Failing
Incident Report for Flexera System Status Dashboard
Postmortem

Description: Flexera One – SaaS Manager – EU – Scheduled Integration Tasks were Failing
Timeframe: March 7th, 4:31 AM to March 7th, 4:57 AM PST

Incident Summary:

On Tuesday, March 7th, at 4:31 AM PST, we received reports of customers experiencing an issue with the Managed Application scheduled integration tasks failing in the EU region. As a result, some customers may have experienced issues accessing new data via Managed Applications or when adding a new Managed Application(s) in SaaS Manager.

An investigation revealed that the issue was caused by certain services responsible for managing integration tasks not working correctly.

To resolve the problem, technical staff restarted the affected services at 4:57 AM PST and manually re-ran some tasks that had failed, providing immediate relief to impacted customers. The issue was identified as a problem during the deployment of recent stability updates, which was addressed by properly redeploying the services.

Health checks confirmed that the services had resumed normal operations, and no further issues were observed. On March 8th, the technical staff verified that the previously failed tasks had been completed successfully.

Root Cause:

The root cause was identified as a problem during the deployment of recent stability updates, which included the affected services responsible for managing tasks. This caused these services to not work correctly, resulting in Managed Application scheduled integration tasks failing in the EU region.

Corrective Action:

  1. The affected services were restarted by technical staff to resolve the issue.
  2. Technical staff manually re-ran some tasks that had failed, providing immediate relief to impacted customers.
  3. The problem was identified and addressed by redeploying the services correctly.
  4. We are evaluating our monitoring capabilities to ensure we can identify and fix similar errors in a timely manner in the future.
Posted Mar 15, 2023 - 12:33 PDT

Resolved
The technicians have been closely monitoring the environment, and the scheduled tasks are operating as expected without any additional failures. This incident has been resolved.
Posted Mar 07, 2023 - 12:58 PST
Monitoring
Incident Description: Technical staff identified an issue with the Managed Application scheduled integration tasks failing in the EU region. As a result, some customers may have experienced issues accessing new data via Managed Applications or when adding a new Managed Application(s) in SaaS Manager.

Priority: P2

Restoration Activity: Technical staff have identified the issue and completed remediation activities. In addition, health checks have confirmed services are now stable.

The scheduled tasks are running successfully now and the tasks that had previously failed will be re-run at their scheduled time.
Posted Mar 07, 2023 - 05:46 PST
This incident affected: Flexera One - IT Asset Management - Europe (IT Asset Management - EU SaaS Manager).