Our monitoring and health checks have confirmed that the issue has been fully resolved, and all services are now operating as expected.
Posted Feb 18, 2025 - 12:18 PST
Monitoring
Our technical team has taken corrective measures, and we are conducting further validation to ensure full functionality. Monitoring is ongoing to confirm there are no lingering impacts. We will provide further updates as validation progresses.
Posted Feb 18, 2025 - 11:43 PST
Investigating
Incident Description: We are currently experiencing an issue affecting the Cloud Cost Optimization (CCO) platform in the EU and NA regions. While some pages are still operational, customers may experience issues when accessing pages displaying cost data.
Priority: P2
Restoration Activity: Our technical team is actively investigating the issue and working to restore functionality. We will provide further updates as we continue resolving the incident.
Posted Feb 18, 2025 - 11:31 PST
This incident affected: Flexera One - Cloud Management - Europe (Cloud Cost Optimization - EU) and Flexera One - Cloud Management - North America (Cloud Cost Optimization - US).