Flexera One - IT Asset Management - All Regions - Inventory Processing Delays

Incident Report for Flexera System Status Dashboard

Resolved

Data processing has remained stable across all regions following the rollback of the recent change. After extended monitoring, inventory data is flowing normally and no further issues have been observed. As all processing has returned to expected behavior, this incident is now considered resolved.
Posted Dec 02, 2025 - 17:40 PST

Monitoring

Our teams have completed the rollback of the recent change, and data processing has resumed across all regions. Inventory data is now flowing again in APAC, US, and EU. Some customers may still see delayed updates while the remaining backlog is processed, but this is expected to clear as processing continues. We are actively monitoring the service to ensure full restoration and will provide further updates as needed.
Posted Dec 02, 2025 - 14:08 PST

Identified

Our teams identified a recent change that required rollback. Following this action, data processing has resumed in the APAC and US regions. Processing in the EU region is still being restored, and customers in that region may continue to experience delays in inventory data updates. We are continuing to monitor progress across all regions and will provide further updates as restoration efforts continue.
Posted Dec 02, 2025 - 13:14 PST

Investigating

Incident Description: We are currently investigating an issue affecting inventory processing for Flexera One IT Asset Management in the NAM, EU, and APAC regions. While the application remains accessible, affected customers may experience delayed or missing inventory updates, and some beacon interfaces may appear as not connected even though uploads have occurred. Usage data continues to process normally at this time.

Priority: P2

Restoration Activity: Our technical teams are actively engaged and are investigating a disruption in the flow of inventory data to the IT Asset Management service. Further updates will be provided as we work to identify the cause and restore full processing.
Posted Dec 02, 2025 - 12:20 PST
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Beacon Communication, IT Asset Management - US Inventory Upload), Flexera One - IT Asset Management - Europe (IT Asset Management - EU Beacon Communication, IT Asset Management - EU Inventory Upload), and Flexera One - IT Asset Management - APAC (IT Asset Management - APAC Beacon Communication, IT Asset Management - APAC Inventory Upload).