Flexera One - NA - Intermittent Access/Login Issues

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One – North America – Intermittent Access/Login Issues

Timeframe: December 3, 2025, 5:08 AM PST – December 3, 2025, 11:05 AM PST

Incident Summary

On December 3, 2025, at approximately 5:08 AM PST, our teams identified intermittent login behavior affecting the North America region. During this period, some customers may have experienced slow or unsuccessful login attempts, while subsequent retries often succeeded. Other regions were not affected.

Internal monitoring showed intermittent timeouts and slowness beginning at around the same time an outage was reported by our external authentication service provider. Their disruption included elevated delays and timeouts within their North America infrastructure. The timing and nature of the behavior observed in Flexera One aligned closely with this provider-side instability.

As the provider-side outage progressed, intermittent failures continued for some users, while login attempts succeeded for others. Technical teams confirmed that all Flexera services, including authentication workflows within our environment, were operating normally, and no changes or adjustments were required on our end.

Login behavior stabilized as the provider’s outage began to clear. Once the provider confirmed full restoration of service, normal access patterns were observed, and no further issues were reported.

The incident was fully resolved on December 3, 2025, at 11:05 AM PST.

Root Cause

The intermittent login behavior in the North America region was the result of instability at our external authentication service provider. During the incident window, the provider experienced elevated delays and timeouts within their North America infrastructure, which affected the completion of some authentication requests.

All Flexera services, including authentication workflows, were operating normally during this time, and no adjustments were required on our end. Login behavior normalized once the provider restored their services.

Remediation Actions

  1. Incident Correlation and Assessment: Our teams reviewed authentication workflows and confirmed that all internal services were operating as expected. The intermittent behavior was correlated with the provider’s reported instability during the same time window.
  2. Monitoring and Validation: Internal monitoring and health checks were used to track authentication behavior as the provider’s outage progressed and to validate when login attempts began succeeding consistently.
  3. Customer Impact Observation: Health checks and internal tests showed that access often succeeded on retry and that the behavior was intermittent. No widespread or sustained login failures were observed.
  4. Stability Confirmation and Incident Closure: Once the provider restored their services and authentication behavior remained stable without further issues, the incident was closed.

Future Preventative Measures

Operational Resilience During Provider Disruptions: This incident highlighted the importance of operational resilience during intermittent service provider disruptions. While the observed behavior was intermittent and limited in scope, Flexera’s monitoring systems detected the behavior, and multiple technical teams were mobilized promptly to assess the impact, validate internal service health, and correlate the observed behavior with external factors. These response and investigation practices will continue to be applied to ensure consistent handling of similar provider-side events.

Posted Dec 16, 2025 - 15:10 PST

Resolved

Our service provider has resolved the outage that was contributing to intermittent login issues in the North America region. Access has been monitored for an extended period and continues to remain stable and functioning normally, with no further login failures or timeouts observed. This incident is now closed.
Posted Dec 03, 2025 - 09:49 PST

Monitoring

Our teams have completed an initial assessment and confirmed that the intermittent login issues observed earlier were related to an outage on our authentication provider’s side. Our services have been operating as expected, and no changes were required within the Flexera One environment.

No further login issues have been observed at this time. However, as the provider-side outage is still ongoing, intermittent timeouts may still be possible. We are monitoring the situation closely and will provide additional updates as more information becomes available.
Posted Dec 03, 2025 - 09:02 PST

Investigating

Incident Description: We are evaluating reports of intermittent issues when accessing Flexera One in the North America region. Some customers may experience slow or unsuccessful login attempts, while access may continue to work normally for others.

Priority: P2

Restoration Activity: Our technical teams are reviewing the behavior and working to determine the scope and underlying cause. Intermittent recovery has been observed, but login attempts may still fail for some users. We will continue to monitor closely and provide further updates as more information becomes available.
Posted Dec 03, 2025 - 06:49 PST
This incident affected: Flexera One - IT Visibility - North America (IT Visibility US), Flexera One – APIs – North America (api.flexera.com), Flexera One - Cloud License Management - North America (Cloud License Management - US), Flexera One - Cloud Commitment Management (Cloud Commitment Management - US), Flexera One - IT Asset Management - North America (IT Asset Management - US Login Page, IT Asset Management - US SaaS Manager), and Flexera One - Cloud Management - North America (Cloud Cost Optimization - US).