Flexera One – IT Visibility – All Regions – Export Failures

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One – IT Visibility – All Regions – Export Failures

Timeframe: March 7, 2026, 8:52 AM PST to March 7, 2026, 5:13 PM PST

Incident Summary

On Saturday, 7 Mar 2026, at 8:52 AM PST, our teams identified an issue affecting Flexera One – IT Visibility in all regions where monitoring alerts and customer reports indicated failures in export functionality. Our technical teams were promptly engaged and the issue was isolated to a query, where export requests were failing during execution.

Initial investigation determined that the failures were caused by a recent deployment that had successfully passed staging validation; however, the behavior in production unexpectedly differed, resulting in errors when customers attempted to generate or download export files. Our technical teams identified a flaw in the query design and developed a fix to refine the query logic, significantly improving execution reliability.

The fix was validated in staging and then deployed in a phased manner across regions. APAC was restored first, confirming the effectiveness of the solution. Deployment to EU followed and completed successfully, while NAM required additional time for full propagation before export operations returned to normal. Continuous monitoring after deployment confirmed that export functionality was fully restored across all regions by 5:13 PM PST.

Root Cause

The issue was introduced during a planned deployment where a query behavior change, although validated in staging, did not function as expected in the production environment, resulting in export failures.

Contributing Factors:

  • A discrepancy between staging and production environments led to differences in query execution behavior.
  • The query design required adjustments to align with production data handling patterns.
  • Pre-deployment validation did not fully capture this variation in behavior.

Remediation Actions

The following remediation steps were implemented to restore service functionality:

  • Refined the query logic to align with expected production behavior and ensure consistent execution.
  • Validated the updated query in a controlled staging environment prior to release.
  • Deployed the fix in a phased manner across APAC, EU, and NAM regions to ensure stability.
  • Performed post-deployment validation to confirm successful export functionality across all regions.
  • Continued monitoring to ensure sustained stability and expected system behavior.

Future Preventative Measures

  • Production-Scale Validation Enhancement - Improve pre-release validation to better simulate real-world production data volumes and usage patterns.
  • Query Performance & Scalability Testing Improvements - Introduce stricter performance benchmarks and scalability testing for queries used in high-volume operations such as exports.
  • Enhanced Monitoring & Proactive Alerting - Expand monitoring coverage and implement proactive alerting for export failures to reduce detection and response time.
Posted Apr 06, 2026 - 04:58 PDT

Resolved

Our technical teams have implemented corrective measures to address the issue affecting export functionality within Flexera One – IT Visibility. Post-deployment validation confirms that exports and related query services are operating normally across all regions. This incident has now been resolved. A detailed root cause analysis report will be shared in the coming days.
Posted Mar 07, 2026 - 19:35 PST

Update

Our technical teams have deployed a fix to address the export failures. Early validation indicates that export functionality has improved in some regions, and we are continuing to monitor as the changes propagate across all regions. Further updates will be provided as validation progresses.
Posted Mar 07, 2026 - 12:56 PST

Identified

Our technical teams continue to investigate the issue. A fix has been identified and is currently undergoing testing. We will provide further updates as progress is made.
Posted Mar 07, 2026 - 10:39 PST

Investigating

Incident Description: We are currently investigating an issue affecting export functionality within Flexera One – IT Visibility for customers in the North America (NAM), Europe (EU), and Asia-Pacific (APAC) regions. As a result, customers may experience failures when attempting to generate or download exports.

Priority: P2

Restoration Activity: Our technical teams have been engaged and are actively working to identify the underlying cause and implement remediation to restore normal export functionality. We are monitoring the situation closely and will provide further updates as progress is made.
Posted Mar 07, 2026 - 09:07 PST
This incident affected: Flexera One - IT Visibility - North America (IT Visibility US), Flexera One - IT Visibility - Europe (IT Visibility EU), and Flexera One - IT Visibility - APAC (IT Visibility - APAC).