Flexera One - Technology Intelligence Platform/IT Visibility - APAC - Web UI errors

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One - Technology Intelligence Platform/IT Visibility - APAC - Web UI errors

Timeframe: March 12, 2025, 7:53 AM PDT to March 12, 2025, 9:05 PM PDT

Incident Summary

On Wednesday, March 12, 2025, at 7:53 AM PDT, users in the APAC region began encountering errors while accessing Technology Intelligence (TI Platform) report pages. The issue affected all APAC organizations, with failures observed across report pages related to software, hardware, normalization statistics, and other TI Platform data. There was no reported impact in the EU or NA regions.

After receiving the initial reports around 8:41 PM PDT, technical teams identified at 8:54 PM PDT that the credentials used by the backend service responsible for rendering reports in APAC had expired. These credentials were intended to be rotated automatically and were successfully generated by the automation workflow, but they were not consumed by the backend service, resulting in continued use of expired credentials.

By 9:05 PM PDT, updated credentials were deployed, and access to the affected pages was fully restored. The service has since continued functioning as expected across all impacted organizations.

Root Cause

Primary Root Cause:

The backend service responsible for rendering Technology Intelligence report pages in the APAC region failed due to expired credentials. The credentials had not been rotated in time, leading to service disruption.

Contributing Factor:

A misconfigured scheduling interval caused the credential rotation job to execute without successfully updating the credentials, allowing them to expire unnoticed.

Remediation Actions

  1. Issue Identification: Technical teams diagnosed the root cause as expired credentials in the backend authentication flow.
  2. Credential Update: The expired credentials were manually updated, restoring access to the affected report pages.
  3. Service Validation: Access to all impacted pages was confirmed to be functioning as expected following the update.

Future Preventative Measures

  1. Rotation Schedule Correction: The credential rotation schedule is being adjusted to follow a consistent and reliable cycle.
  2. Automation Logic Improvement: We are reviewing and enhancing the automation logic to ensure credentials are rotated prior to expiration.
  3. Post-Rotation Validation: Additional checks are being explored to verify that backend services successfully recognize updated credentials after each rotation.
Posted Mar 29, 2025 - 08:39 PDT

Resolved

Incident Description: Our teams have detected an issue affecting Flexera One Technology Intelligence web UI in the APAC region. The affected customers may encounter an error message when attempting to access ITV/Technology Intelligence Platform Web UI pages.

Priority: P2

Restoration Activity: Our teams have been actively engaged and successfully identified the root cause of the issue. They have implemented the necessary configuration changes and confirmed that the WebUI is now functioning properly.
Posted Mar 12, 2025 - 21:13 PDT
This incident affected: Flexera One - IT Visibility - APAC (IT Visibility - APAC).