The issue impacting access to Custom Reports within IT Visibility in the NAM region has been resolved. A corrective update has been deployed, and validation confirms that reports are loading as expected.
We will continue to monitor the environment to ensure stability. A formal post-mortem report outlining the detailed root cause, corrective actions, and future preventative measures will be published in the coming days.
Posted Feb 19, 2026 - 12:57 PST
Update
Our investigation has identified the cause of the issue impacting Custom Reports in the NAM region. The behavior is related to how report access is being evaluated for certain organizations.
We have validated a corrective action and are working to implement a broader resolution. We will provide another update once the permanent fix is confirmed.
Posted Feb 19, 2026 - 11:27 PST
Identified
Our investigation has identified a behavior affecting access controls for Custom Reports in the NAM region. This condition is preventing reports from loading for certain organizations.
We are actively testing a targeted adjustment to validate the behavior and are working toward resolution. We will provide another update once validation is complete.
Posted Feb 19, 2026 - 11:07 PST
Investigating
Incident Description: We are investigating an issue affecting access to Custom Reports within IT Visibility in the NAM region. Customers may experience errors when attempting to access Custom Reports.
At this time:
• Out-of-the-box reports remain available • EU and APAC regions are not impacted • The issue is isolated to Custom Reports functionality
Priority: P2
Restoration Activity: Our technical teams are actively investigating to determine the scope and root cause. We will provide further updates as more information becomes available.
Posted Feb 19, 2026 - 10:08 PST
This incident affected: Flexera One - IT Visibility - North America (IT Visibility US).