Snow Atlas- APAC- Error 500 - internal server error

Incident Report for Flexera System Status Dashboard

Resolved

Our teams continue to monitor the environment closely. No ongoing customer-facing impact had been reported, and systems remain stable with the current workaround in place.

Root cause investigation efforts are still ongoing, and technical teams continue to validate a permanent fix to prevent recurrence. Further updates will be shared via a post-mortem report.
Posted May 29, 2026 - 03:23 PDT

Monitoring

Incident Description: We are currently experiencing an issue affecting a subset of Snow Atlas customers in the APAC region. Affected users may encounter HTTP 500 errors when accessing the application.

Priority: P2

Restoration Activity: Our technical teams are actively investigating the issue and have identified a potential root cause. As an immediate mitigation, service restarts were performed on the affected components, which restored functionality for impacted customers. Teams are continuing their investigation to implement a permanent resolution and are closely monitoring the environment to ensure ongoing stability. Further updates will be provided as more information becomes available.
Posted May 28, 2026 - 20:07 PDT
This incident affected: Snow Atlas (Snow Atlas - Australia, Snow Atlas API - Australia).