This issue has been resolved and all services have returned to normalcy.
Posted Sep 20, 2025 - 02:12 PDT
Update
The underlying cause has been identified as part of ongoing efforts to enhance our data management capabilities to support future growth and reliability. During this process, some data processing tasks have taken longer than expected, resulting in delays for certain customers.
Recovery efforts are ongoing, and we are seeing steady improvements in processing times. We are monitoring progress closely and will provide further updates as more information becomes available.
Posted Sep 19, 2025 - 13:53 PDT
Identified
Incident Description: We are currently investigating a service degradation affecting inventory processing for IT Visibility services in the NAM region. The system remains accessible, and customers can continue to use the APIs and UIs; however, they may encounter data import timeouts and delays in inventory updates.
Priority: P2
Restoration Activity: Our technical teams are actively investigating and suspect that an ongoing database migration may be causing the issue. To mitigate the impact, backend services have been scaled out. We will provide further updates, including an estimated recovery time, as soon as they become available.
Posted Sep 19, 2025 - 03:48 PDT
This incident affected: Flexera One - IT Visibility - North America (IT Visibility US).