Our technical teams continue to work through the backlog recovery process. Recovery activities are being carried out cautiously to avoid overwhelming downstream services and to ensure platform stability throughout the restoration process.
Posted May 11, 2026 - 04:16 PDT
Monitoring
Our technical teams have successfully designed and implemented a fix. Services are now operating normally, and backlog processing is underway for the data accumulated during the incident.
Posted May 10, 2026 - 22:06 PDT
Investigating
Incident Description: We are investigating an issue impacting IT Visibility (ITV) services in the US Production environment. Affected customers may experience delays in normalized inventory updates appearing in ITV .
Priority: P2
Restoration Activity: Our technical teams have identified that a backend service is experiencing elevated request throttling from an upstream cloud provider dependency, resulting in delayed inventory processing. Teams are actively investigating the issue and working to restore normal processing. We are monitoring the environment closely and will continue to provide updates as progress is made toward full restoration.
Posted May 10, 2026 - 20:31 PDT
This incident affects: Flexera One - IT Visibility - North America (IT Visibility US).