Flexera One - NAM - Access Disruption

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One – NAM – Access Disruption

Timeframe: April 2, 2026, 12:39 PM PDT – April 2, 2026, 1:02 PM PDT

Incident Summary

On April 2, 2026, at approximately 12:39 PM PDT, an issue was identified affecting access to the Flexera One application in the North America (NAM) region. During this period, customers may have experienced difficulties accessing the Flexera One application.

Technical teams began investigating immediately and identified elevated load affecting an access-related backend service involved in authentication and request processing. This degraded service behavior temporarily impacted customer access in the NAM region.

Mitigation actions were initiated during the incident response, including reverting recent changes associated with the affected service. Following these actions, system performance improved and customer access was restored.

By April 2, 2026, at approximately 1:02 PM PDT, access to the Flexera One application in NAM had returned to expected operation. After validation and monitoring confirmed stable recovery, the incident was considered resolved.

Root Cause

The incident was caused by a recent service change that introduced inefficient database request behavior within an access-related backend service. This created elevated load in the production environment and temporarily disrupted customer access to the Flexera One application.

Remediation Actions

The following actions were taken during the incident response:

  1. Incident Detection and Response Initiated: Technical teams were alerted to the access disruption affecting the NAM region and began immediate investigation.
    Impact Isolation: It was confirmed that the customer-facing impact was limited to the NAM region.
  2. Service Review and Diagnosis: Technical teams reviewed recent changes and identified elevated load affecting the related backend service.
  3. Corrective Action Applied: Recent changes associated with the affected service were reverted to restore normal operation.
    Service Restoration Verification: Customer access and application performance were validated following the mitigation actions.
  4. Post-Recovery Monitoring: Services were monitored after restoration to confirm continued normal operation.

Future Preventative Measures

This incident highlighted the importance of validating performance-related service changes under production-scale demand conditions.

Based on this experience, the following measures are being applied:

  1. Performance Validation Enhancements: We are reviewing pre-production validation approaches to better identify query efficiency issues under higher traffic conditions.
  2. Deployment Safeguards: We are strengthening staged rollout and monitoring practices for changes affecting access-related services.
  3. Database Access Optimization: Following service restoration through rollback of the recent change, technical teams are addressing the inefficient database access behavior identified during the investigation before similar changes are reintroduced.
Posted Apr 16, 2026 - 22:30 PDT

Resolved

Technical teams identified a recent service change as the source of the disruption and reverted the affected changes during the incident. Following those actions, customer access in the NAM region was restored. Services have remained stable since recovery, and our technical teams continue to monitor closely to ensure sustained stability.
Posted Apr 02, 2026 - 13:47 PDT

Monitoring

Service has been restored, and customer access in the NAM region is operating normally at this time. Our technical teams are continuing to monitor closely to ensure sustained stability following the mitigation steps that were implemented.
Posted Apr 02, 2026 - 13:22 PDT

Identified

Incident Description: We identified an issue affecting access to the Flexera One application in the North America (NAM) region. During the incident window, customers may have experienced difficulties accessing the application.

Priority: P1

Restoration Activity: Technical teams are engaged and actively implementing mitigation steps to restore access in the NAM region. We will continue to provide updates as more information becomes available.
Posted Apr 02, 2026 - 13:02 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Beacon Communication, IT Asset Management - US Inventory Upload, IT Asset Management - US Login Page, IT Asset Management - US Batch Processing System, IT Asset Management - US Business Reporting, IT Asset Management - US SaaS Manager, IT Asset Management - US Restful APIs), Flexera One - IT Visibility - North America (IT Visibility US), Flexera One - Cloud License Management - North America (Cloud License Management - US), Flexera One - Cloud Commitment Management (Cloud Commitment Management - US), and Flexera One - Cloud Management - North America (Cloud Cost Optimization - US, Cloudscape).