Our technical teams have confirmed that all affected functionality has been fully restored.
Validation has completed successfully, including Elastigroup creation and page load performance. We are marking this incident as resolved and will continue standard monitoring.
Posted May 13, 2026 - 10:02 PDT
Monitoring
Our technical teams have completed initial restoration actions, and validation confirms that Elastigroup creation is now working successfully.
We are continuing to monitor page load performance and overall functionality before confirming full resolution.
Posted May 13, 2026 - 09:46 PDT
Identified
Our technical teams have identified that the issue is related to a recent change, and the change is currently being reverted.
Initial validation indicates that customers are now able to create Elastigroups again. We are continuing to validate page load performance and overall functionality before confirming full recovery.
Posted May 13, 2026 - 08:45 PDT
Investigating
Incident Description: We are currently investigating degraded performance affecting Spot Elastigroup for AWS customers. Customers may experience delays when loading the Elastigroup page and may be unable to create new Elastigroups.
Priority: P2
Restoration Activity: Our technical teams are actively investigating and working to restore normal functionality. Current findings indicate the impact is limited to AWS customers. Validation is ongoing to confirm the full scope of impact.