Inventory ingestion has been fully restored, and data processing is operating normally. We are proactively replaying customer third-party data to ensure completeness and prevent any missed updates. All other third-party data sources are already up to date and processing as expected
Posted Mar 17, 2026 - 01:11 PDT
Identified
Incident Description: We are currently investigating an issue affecting inventory ingestion within Flexera One – IT Visibility (ITV) in the EU production environment. The service is experiencing a processing backlog, which may result in delays in inventory updates from third-party data sources. ITV user interfaces and APIs remain fully accessible, and core functionality is not impacted.
Priority: P3
Restoration Activity: Our technical teams have identified the likely cause as resource constraints in a managed caching service. We have increased capacity and are actively evaluating system recovery while working to clear the backlog. We are closely monitoring the situation and will provide further updates as progress is made.
Posted Mar 16, 2026 - 21:56 PDT
This incident affected: Flexera One - IT Visibility - Europe (IT Visibility EU).