Flexera One - IT Visibility - EU - Data Processing Delayed
Incident Report for Flexera System Status Dashboard
Postmortem

Description: Flexera One - IT Visibility - EU - Data Processing Delayed

Timeframe: October 29th, 7:05 AM to October 29th, 9:28 AM PDT

Incident Summary

On Tuesday, October 29, 2024, at approximately 7:05 AM PDT, we experienced a delay in data processing for IT Visibility (ITV) Dashboards in the EU region. While customers could still access the ITV Dashboards, the displayed data was outdated due to interruptions in real-time updates. The issue did not impact other ITV services, including the API, which continued to operate as expected.

Our service provider identified a temporary disruption in their data integration systems, impacting data updates for multiple customers. To prevent further data inconsistencies, we temporarily paused our data integration process in the EU region while the provider worked to resolve the issue.

Once the provider restored their services, we resumed data processing and monitored closely as the backlog was cleared. By 9:28 AM PDT, data processing had returned to real-time status, and platform stability was fully restored.

Root Cause

The delay in data processing for IT Visibility (ITV) Dashboards in the EU region was due to a temporary disruption in our service provider’s data integration systems. This disruption impacted multiple customers relying on similar data processing workflows. As a result, dashboards displayed outdated information while data continued to accumulate in the backlog.

Remediation Actions

  1. Service Provider Collaboration: A high-priority support ticket was opened with the service provider to expedite their investigation and resolution efforts.
  2. Disabling Data Integration: Following guidance from the service provider, we temporarily disabled the data integration process in the EU region to prevent further inconsistencies in data.
  3. Monitoring and Status Updates: Active monitoring was initiated to track any changes, and status updates were regularly posted to keep customers informed.
  4. Re-enabling Data Processing: Upon confirmation from the provider that the issue was resolved, the data integration process was re-enabled to begin clearing the backlog.
  5. Extended Monitoring: Continuous monitoring ensured that data processing resumed as expected, allowing the system to return to real-time data updates across ITV Dashboards.

Future Preventative Measure

• Collaborative Post-Incident Review: A comprehensive post-mortem review has been requested from our service provider to thoroughly understand the root cause. Based on the findings, we will work closely with their team to implement enhanced safeguards and preventive strategies, reinforcing data processing reliability and minimizing the risk of recurrence in similar incidents.

Posted Nov 07, 2024 - 17:37 PST

Resolved
The data processing issue has been resolved, and all backlogged data has been processed. Dashboards are now fully updated and reflecting real-time data.
Posted Oct 29, 2024 - 09:33 PDT
Monitoring
Our service provider has indicated that the underlying issue has been resolved and requested that we re-enable our data processing. This process has been re-enabled and is currently underway, though some delays may occur as we work through the backlog.

We will provide further updates as soon as functionality is fully restored.
Posted Oct 29, 2024 - 09:16 PDT
Identified
Incident Description: We are currently experiencing delays in data processing for IT Visibility Dashboards in the EU region, resulting in outdated data displayed to users. While the dashboards remain accessible and the UI is responsive, recent data updates are not currently reflected.

Priority: P2

Restoration Activity: The issue has been traced to our service provider, affecting the update of dashboard data. Our team is actively collaborating with their support team to restore service. We are closely monitoring the situation and will provide updates as more information becomes available.
Posted Oct 29, 2024 - 07:28 PDT
This incident affected: Flexera One - IT Visibility - Europe (IT Visibility EU).