IT Visibility - EU and NA - Data Processing has been Delayed

Incident Report for Flexera System Status Dashboard

Postmortem

Description: IT Visibility - EU & NA - Data Processing was Delayed

Timeframe: May 5th, 07:00 AM PDT to May 6th, 6:38 AM PDT

Incident Summary:

On May 6th, at 2:32 AM PDT, technical staff observed a processing backlog in both NA and EU regions. As a result, customers may have experienced delays retrieving inventory data due to a processing backlog. EU data was up to 9 hours out of date and NA was up to 3 hours out of date.

Technical staff found that one of the consumer cluster data processing devices was unable to read data from the data streaming service. Additional subject matter experts were engaged from the other areas to assist with the investigation. Further investigation revealed that data encryption had been enabled on the streaming service and the impacted device did not have the correct roles assigned, which rendered its ability to decrypt and read data from the service.

Staff updated the device’s access roles in both EU and US at 3:35 AM PDT, following which health checks were completed successfully. At 5:23 AM PDT, the NA backlog processing was completed, and the EU backlog processing was completed at 6:38 AM PDT. After additional monitoring, technical staff declared the incident to be resolved.

Root Cause:

Infrastructure deployment across the EU and US environments altered some of the policies that enable the consumer storage cluster to decrypt the data from the streaming service.

Corrective Action:

• Technical staff updated the device’s access roles in both EU and US which authorized the device to decrypt and read data from the streaming service successfully
• Technical staff will work on enhancing coordination among teams during deployments to avoid service disruptions in the future

Posted Sep 23, 2022 - 15:31 PDT

Resolved

EU Backlog processing has been completed. The inventory data for both NA and EU is processing in real-time now. This incident has been resolved.
Posted May 06, 2022 - 06:46 PDT

Update

EU Backlog Processing is still ongoing and significant progress has been made in the last hour.
Posted May 06, 2022 - 05:35 PDT

Update

A fix has been implemented successfully. Backlog processing is now complete in NA. EU backlog processing is still in progress.
Posted May 06, 2022 - 04:21 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 06, 2022 - 03:29 PDT

Investigating

Incident Description:
Customers may experience delays before inventory data is visible due to a processing backlog. EU data may be up to 9 hours out of date and NA may be up to 3 hours out of date.

Priority: P2

Restoration activity:
Technical teams have been engaged and are currently investigating.
Posted May 06, 2022 - 03:24 PDT
This incident affected: Flexera One - IT Visibility - North America (IT Visibility US) and Flexera One - IT Visibility - Europe (IT Visibility EU).