Flexera One UI - NA - Service Outage

Incident Report for Flexera System Status Dashboard

Resolved

The issue has been resolved, and the platform is fully operational. We have also completed validation to ensure everything is working as expected. No further problems have been observed, and this incident is now considered closed.
Posted Jun 24, 2025 - 06:58 PDT

Monitoring

The team has successfully reverted the recent change, and user access to the platform has been restored. The issue appears to be resolved, and we are conducting additional validation tests to confirm full system functionality before closing the incident.
Posted Jun 24, 2025 - 06:47 PDT

Identified

Incident Description: We are currently investigating an ongoing outage affecting the Flexera One UI in the North America region. Customers may be unable to log in or access the platform at this time.

Priority: P1

Restoration Activity: Our technical teams are actively investigating the issue and working to resolve it. A rollback of the most recent release is in progress as we take targeted steps to restore service. Further updates will be shared as we make progress.
Posted Jun 24, 2025 - 06:15 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Beacon Communication, IT Asset Management - US Inventory Upload, IT Asset Management - US Login Page, IT Asset Management - US Batch Processing System, IT Asset Management - US Business Reporting, IT Asset Management - US SaaS Manager), Flexera One - IT Visibility - North America (IT Visibility US), Flexera One – APIs – North America (api.flexera.com), Flexera One - Cloud License Management - North America (Cloud License Management - US), and Flexera One - Cloud Management - North America (Cloud Cost Optimization - US, Cloudscape).