Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 21, 2025 - 00:00 PDT
Scheduled
Flexera will be conducting updates to Power BI data models and reports on U.S. instances. During this maintenance window, customers using the Technology Intelligence (TI) platform, IT Visibility (ITV), and Cloud License Management (CLM) may experience temporary disruption.
Power BI reports may either not display the most up-to-date data or may be briefly unavailable when attempting to load.
Maintenance Window:
PDT: Apr 21 00:00 am - 02:00 am CDT: Apr 21 02:00 am - 04:00 am CEST: Apr 21 09:00 am - 11:00 am AEST: Apr 21 05:00 pm - 07:00 pm UTC: Apr 21 07:00 am - 09:00 am EDT: Apr 21 03:00 am - 05:00 am IST: Apr 21 12:30pm - 02:30pm
Posted Apr 17, 2025 - 18:31 PDT
This scheduled maintenance affected: Flexera One - IT Visibility - North America (IT Visibility US) and Flexera One - Cloud License Management - North America (Cloud License Management - US).