Flexera One- IT Asset management - NAM - Inventory processing failures

Incident Report for Flexera System Status Dashboard

Resolved

This incident was inadvertently marked as resolved with an update intended for a separate incident. Inventory processing recovery remains under monitoring as the remaining backlog continues to clear. Technical teams continue to observe successful file processing and stable service operation.

Ongoing recovery updates and backlog monitoring will continue under the newly created incident: https://status.flexera.com/incidents/vztp63wmxjjb

We will provide further updates as backlog recovery progresses and recovery validation continues.
Posted Sep 24, 2026 - 13:32 PDT

Update

Our technical teams continue to observe successful inventory file processing and stable service operation following the recovery actions. Validation through monitoring confirms that affected inventory files are processing successfully.

Backlog recovery is currently in progress, with inventory processing queues continuing to decrease as files are processed. Technical teams are actively monitoring recovery progress and overall service health while the remaining backlog is cleared.

We will continue to provide updates as recovery progresses.
Posted Sep 24, 2026 - 11:42 PDT

Monitoring

Our team performed targeted pod restarts, following which inventory file processing resumed successfully for all affected customers. Successful processing has been validated through logs and monitoring graphs. We will continue to closely monitor the services to ensure continued stability and provide further updates as additional information becomes available.
Posted Sep 24, 2026 - 07:32 PDT

Update

Further investigation indicates that the issue appears to be associated with the service responsible for transferring inventory data to ITAM.
Our technical teams are continuing to investigate the issue and are working to identify the underlying cause and determine the appropriate remediation. We will continue to provide further updates as more information becomes available.
Posted Sep 24, 2026 - 05:27 PDT

Investigating

Incident Description: We identified an issue affecting inventory processing in Flexera One IT Asset Management (ITAM) in the NAM region, impacting a subset of customers. As a result, some inventory uploads are not being processed successfully, causing inventory data displayed in Flexera One ITAM to be delayed and not reflect the most recently uploaded inventory.

Priority: P2

Restoration Activity: Our technical teams are actively investigating the issue to identify the underlying cause and implement a fix. We are continuing to monitor the situation closely and will provide further updates as the investigation progresses.
Posted Sep 24, 2026 - 03:11 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Inventory Upload).