Flexera One - IT Asset Management - All Regions - Third-Party Inventory Import Issues

Incident Report for Flexera System Status Dashboard

Monitoring

Teams have completed the production deployment of the fix and are monitoring upload behavior across impacted regions.

Initial production results are positive, and larger third-party inventory uploads are now being received successfully. Teams are continuing to validate downstream processing to confirm imports complete as expected.

We will provide another update once additional production validation is complete.
Posted Jun 05, 2026 - 11:21 PDT

Identified

Our teams have completed additional validation of the fix in the test environment, including larger uploads and multiple import paths. Results continue to be positive, and teams are working through the next steps needed for a controlled production rollout.

We are continuing to validate remaining scenarios and review upload-processing behavior to ensure the fix addresses the issue safely before broader deployment.

We will provide another update as rollout planning and validation progress.
Posted Jun 05, 2026 - 11:06 PDT

Update

Our teams have developed and deployed a fix to address the issue affecting data uploads in a test environment. Initial validation indicates improved upload success rates, and teams are currently performing comprehensive testing to verify end-to-end processing and data integrity before proceeding with a broader rollout.

In parallel, the investigation into intermittent request-processing behavior remains ongoing. Teams are continuing to analyze system performance and stability to ensure the underlying issues are fully addressed .

We will continue to monitor progress closely and provide additional updates as more information becomes available.
Posted Jun 05, 2026 - 01:15 PDT

Investigating

Incident Description: We are investigating an issue affecting third-party inventory imports in IT Asset Management. As a result, some customers may experience third-party inventory imports timing out, failing, or remaining in progress longer than expected.

Priority: P2

Restoration Activity: Technical teams have identified that some third-party inventory uploads are not completing successfully after the import package is created. Teams are applying backend mitigation where available while continuing work to restore the standard upload flow.
Posted Jun 04, 2026 - 14:17 PDT
This incident affects: Flexera One - IT Asset Management - North America (IT Asset Management - US Inventory Upload), Flexera One - IT Asset Management - Europe (IT Asset Management - EU Inventory Upload), and Flexera One - IT Asset Management - APAC (IT Asset Management - APAC Inventory Upload).